what rpm should you be at when going 70 mph?
G20.net is the premier Infiniti G20 Nissan Primera Forum on the internet. Registered Users do not see the above ads.
Results 1 to 5 of 5

Thread: what rpm should you be at when going 70 mph?

  1. #1
    G20 Member
    Join Date
    Apr 2010
    Location
    pennsylvania
    Posts
    189

    what rpm should you be at when going 70 mph?

    well i was driving on the highway after fixing my car and i notice i was at 3000 rpm when going 70 mph. rpm keep climbing when im going faster. is this normal? I was wondering if i have fourth gear or not since i believe my car whent into safe mode with the OD light blinking. btw i drive a 2002 g20 auto

  2. Remove Advertisements
    G20.net
    Advertisements
     

  3. #2
    Custom title !!!!!yay
    Join Date
    May 2007
    Location
    AZG FTW
    Posts
    2,456
    3000 seems fine for 70, make sure your OD is on. the faster you go the harder the motor needs to work meaning higher rpm's. I belive safe mode wont let you go over 35mph.
    I cant comment on the OD light blinking as I dont have one :/

  4. #3
    Dude, your bed is a car..
    Join Date
    Jan 2007
    Location
    Illinois
    Posts
    4,567
    at just around 3k sounds about right plus stay just under for better fuel saving

  5. #4
    G20 Member
    Join Date
    Apr 2010
    Location
    pennsylvania
    Posts
    189
    Quote Originally Posted by polg20 View Post
    3000 seems fine for 70, make sure your OD is on. the faster you go the harder the motor needs to work meaning higher rpm's. I belive safe mode wont let you go over 35mph.
    I cant comment on the OD light blinking as I dont have one :/
    My OD light blinks 16 times when i start up the car and i read that this puts the car in safe mode with no fourth gear. However all my gears engaged so i dont know why it still blinks.

  6. #5
    G20 Guru blankman3's Avatar
    Join Date
    Sep 2007
    Location
    socal
    Posts
    1,492
    something electronically wrong. Sounds like ur car is working fine....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •