Not shifting into 4th with overdrive on
G20.net is the premier Infiniti G20 Nissan Primera Forum on the internet. Registered Users do not see the above ads.
Results 1 to 5 of 5

Thread: Not shifting into 4th with overdrive on

  1. #1
    G20 Newbie
    Join Date
    Jun 2005
    Posts
    2

    Not shifting into 4th with overdrive on

    I have a 93 with an AT. Engine runs fine and the transmission shifts smoothly. However, while driving it occasionally drops back into 3rd gear and won't shift back up. After clicking the overdrive button a few times it seems to reset and runs normally but can mess up again later.

    Not only does it not shift up to 4th, but when stuck in 3rd it doesn't perform the same as it normally would with the overdrive off and running in 3rd.

    I read somewhere, I think on a thread here I can no longer find, to replace the battery. I had the battery tested and it's fine. Any suggestions?

  2. Remove Advertisements
    G20.net
    Advertisements
     

  3. #2
    G20 Guru mustang dude's Avatar
    Join Date
    Mar 2004
    Location
    Baton Rouge
    Posts
    1,242
    usually when the transmission won't shift into OD or will shift and then drop back into 3rd.. that usually means the OD band is shot and it is time for a rebuild.. usually it goes in this order, OD fails then the third gear clutch pack starts slipping .. then one day you will find you only have reverse, first, and second. Been there several times!!! Not with the Infiniti but with my mustang.. have broken the lock-up system several times and have limped the car home at 40 mph in 2nd gear
    2002 Toyota Highlander 3.0 VVT-IE V6 (stock)
    1988 Mustang GT (auto) blown tranny
    93 Infiniti G20 (RIP)

  4. #3
    G20 Guru Domiken's Avatar
    Join Date
    Apr 2002
    Location
    Queens-New York
    Posts
    7,569
    Well see in our cars, with the OD OFF function on the car is not supposed to shift into 4th gear, its supposed to stay in third.

    If the OD is on (normal) it should go into 4th, if the little yellow light that says OD OFF is what you are talking about then its not supposed to shift into 4th.

  5. #4
    G20 Senior Member Diamond_G's Avatar
    Join Date
    Oct 2002
    Location
    Virginia
    Posts
    796

    Re: Not shifting into 4th with overdrive on

    Originally posted by Seneca
    I have a 93 with an AT. Engine runs fine and the transmission shifts smoothly. However, while driving it occasionally drops back into 3rd gear and won't shift back up. After clicking the overdrive button a few times it seems to reset and runs normally but can mess up again later.

    Not only does it not shift up to 4th, but when stuck in 3rd it doesn't perform the same as it normally would with the overdrive off and running in 3rd.

    I read somewhere, I think on a thread here I can no longer find, to replace the battery. I had the battery tested and it's fine. Any suggestions?

    That was the same problem my old tranny had... I neglected to get it fixed till my engine went on me....

    You should pull the codes from your ECU. If it doens't have any codes stored about the tranny, take it to a shop and have them look at it.
    Diamond Audio TDX 12D2/Diamond Audio D51200.1 (140.5 db @ 52hz)

  6. #5
    G20 Newbie true grit's Avatar
    Join Date
    Sep 2007
    Location
    San Diego, CA
    Posts
    16
    I think this question is worth repeating. P-11, A/T, with 80K. If you have these SYMPTOMS: Loss of low end power, no 3rd to 4th (No O/D), gas mileage dropped to 17 mpg, no CEL, no codes. TEST: (1)Run car, you'll notice the "Symptoms", (2) Shutoff car, Restart car, the "O/D" light will blink steady spaces 16 times. Now drives normal. FIX: Replace with good battery.
    Checked: Cell is approximately Average 1240-1250. Car off 12.v, Car On 14.5 v. But under load test, indicates 'BAD BATTERY'!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •