car makes a screeching sound when i turn on A/C or heater...
G20.net is the premier Infiniti G20 Nissan Primera Forum on the internet. Registered Users do not see the above ads.
Results 1 to 14 of 14

Thread: car makes a screeching sound when i turn on A/C or heater...

  1. #1
    G20 Senior Member hypesteez's Avatar
    Join Date
    Jun 2008
    Location
    SOCAL.
    Posts
    808

    car makes a screeching sound when i turn on A/C or heater...

    hello my fellow G20.net members. so my car has recently done this stuff..so when i start up my car and turn on my a/c it makes a screeching sound and when i turn on my heater samething....and today when i got out of work it was really cold so now even when i am driving it makes that loud screeching sound. so does anyone know the problem and what i need to fix it cuz its annoying i cant even turn on my a/c or heater..........hopefully you guys can help like u always do thanks!

  2. Remove Advertisements
    G20.net
    Advertisements
     

  3. #2
    G20 Newbie
    Join Date
    Oct 2009
    Location
    BC, CANADA
    Posts
    39
    so there is a screeching sound , but do the components work?
    can you pinpoint the squeaking sound? does it happen when the engine is all warmed up?im leaning on alternator belt.

  4. #3
    Im a organ donor.
    Join Date
    Feb 2008
    Location
    Atlanta
    Posts
    4,843
    http://www.ehow.com/video_2260493_wh...ine-drive.html

    could be the compressor clutch giving up too......just have to diagnosis it one thing at a time. rule out things 1 by 1.

  5. #4
    Lord Crodz javcrodgz's Avatar
    Join Date
    Apr 2006
    Location
    Tempe, AZ
    Posts
    7,204
    have you checked for gremlins in the heater core?

  6. #5
    Questioning Answers ENO's Avatar
    Join Date
    Jan 2006
    Location
    Not Philly area.
    Posts
    6,565
    check your belts....mine does it 1st thing in the morn....for like 2 mins & stops...i need new belts i think....but in the morning its cold, & rubber contracts in the cold....so that might be your issue

  7. #6
    G20 Senior Member hypesteez's Avatar
    Join Date
    Jun 2008
    Location
    SOCAL.
    Posts
    808
    well my heater and a/c work its just when i turn it on. so maybe it might be my belts cuz of the cold i dont know it never did it before.

  8. #7
    Cheap @$$
    Join Date
    Jul 2008
    Location
    Stratford, CT
    Posts
    2,125
    mine does this in the cold when i have the heater on and if i drive through a puddle. so i assume its the belts being cold or wet. probably need to be tightened...

  9. #8
    G20.net Staff
    Super Moderator
    slimlou's Avatar
    Join Date
    Sep 2004
    Location
    Toronto, ON
    Posts
    6,122
    lol same here! I just had new belts put on in the summer, bur had a bit of a coolant leak (since fixed), so this might be my reason. Another thing to check is the belt tension. If it's loose, it will also result in this noise.

  10. #9
    ʎןןnɟ˙˙ǝdoɹƃ Alex's Avatar
    Join Date
    May 2002
    Location
    Columbus, OH
    Posts
    2,773
    Quote Originally Posted by slimlou View Post
    If it's loose, it will also result in this noise.
    +1 check the tension (and condition) of the belts.

  11. #10
    Cheap @$$
    Join Date
    Jul 2008
    Location
    Stratford, CT
    Posts
    2,125
    i should probably lose some weight, its my car screaming

  12. #11
    G20 Senior Member hypesteez's Avatar
    Join Date
    Jun 2008
    Location
    SOCAL.
    Posts
    808
    thanks guys does anyone know how much it will cost to get the belts tightened or replaced?

  13. #12
    G20 Senior Member hypesteez's Avatar
    Join Date
    Jun 2008
    Location
    SOCAL.
    Posts
    808
    got a quote on parts and labor 180 for all 4 new belts, for alternator, powersteering, pulleys, and ac/heater.

  14. #13
    G20.net Staff
    Super Moderator
    slimlou's Avatar
    Join Date
    Sep 2004
    Location
    Toronto, ON
    Posts
    6,122
    ^^^ 4 belts? That's what they told you? Our cars only have two belts! I guess it can be considered a PITA DIY, so paying someone to do it is worth it. I checked my belt (the one going to the alternator, and sure enough, it needs to be tightened.

  15. #14
    G20 Senior Member hypesteez's Avatar
    Join Date
    Jun 2008
    Location
    SOCAL.
    Posts
    808
    yeah they said there are 4 belts ahaha im getting them replaced tomorrow. my car doesnt even start cuz my dumb belts are not gripping.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •