Infiniti G20 Nissan Primera Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
i am looking to purchase this 93 g20 from a used car lot, it was a repo so it is on the cheap, like $800. It has this problem where it usually won't start, it won't even turn over when it does this. Very rarely, it starts and runs perfectly, it sounds awsome. The security light in the dash flashes when you try to turn it over if it doesn't want to start. I know the security system in this car interupts the clutch sensor so it wont turn over so i tried jumping the relays to no avail. I didn't see a fuse for the security system but maybe it's on a fuse for something else. Does anyone have any suggestions for what might be causing the car to not start even though it rarely does, I want to buy this car but I need to make sure it will reliably start before I get rid of my current car to get it.

-Cabal
 

·
Used to own a P10
Joined
·
5,396 Posts
It's very likely the starter. Do you hear a relay click when you turn the key? I had the exact same symptom when my starter was going out -- wouldn't turn over half the time, and then the other half would run great.
 

·
Registered
Joined
·
8,918 Posts
I had the same issue with my daughters P10. Started fine when I bought it, then got intermittent then just gave up. New starter FTW. :thumbsup:
 

·
La-illaha Il-lallah
Joined
·
2,034 Posts
There are two possibilities. I used to always say starter when someone posted this until recently I learned another possibility. It could be your neutral safety switch. There is a pretty easy way of finding out. There is an inhibitor relay in the box right next to the battery. If you bypass this relay and everything starts up fine than it is your neutral safety switch.

To see the location of the relay and read about it click this link...
http://www.g20.net/forum/showthread.php?t=50666&highlight=neutral+safety+switch

To see how to bypass it click this link...
http://www.g20.net/forum/showpost.php?p=529651&postcount=33

I would say try this first and if it doesn't help, its time to change the starter.
 

·
drunken master
Joined
·
10,091 Posts
from what you are saying it sounds like it is a fualt of the security system. does this car have any aftermarket allarm wires under the dash?

i have my orignal starter at 140K i had a intermitan no crank issue and i took my soliniod apart and cleaned connections and never had the problem gain.

If you notice anything else with the car let me know but do l l your realy checks at the time of the insodent it will tel you what is really happening
 

·
Pizdeet kak Trotsky
Joined
·
3,069 Posts
If you have the where with all to buy this, keep the original, fix the 20 then flop the other one yeah ....... Otherwise not on your nelly :)
 
1 - 6 of 6 Posts
Top