Infiniti G20 Nissan Primera Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey everyone I’m new to this forum and the G20 I got this car for cheap because it has some issues and has been sitting around for a few years. So I got it and it had a short in the power wire to the distributor which was no big deal fixed that and now I’m getting spark but I’m not getting fuel and I know this because you spray some starting fluid in manifold it’ll start so I figured the rail and injectors were gummed up so I cleaned the rail out and got new injectors put it back in the car and still no fuel. Checked the fuel pump it’s kicking on and has great fuel pressure so then I looked to see if I’m getting power to the injectors and I’ve got 12v’s to all them but for some reason they aren’t pulsing. I made sure I’ve charged the battery so it’s good and holding a charge and connections are clean and tight so I could rule that out on being a issue and now stumped on why it won’t spray fuel. So I’ve done some reading and heard that the security system could be a issue and when I looked into my car always has the red light blinking until I turn the key on? So I’m hoping any of you G20 gods might be able to help me understand this system or point me in the right direction to go from here!
 

·
Registered
Joined
·
70 Posts
red light blinking until I turn the key on? So I’m hoping any of you G20 gods might be able to help me understand this system or point me in the right direction to go from here!
When you try to start it, what happens (nothing/turns over/sputters/etc.)? Have you checked the spark plugs/cylinders?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
It turns over just fine and on starting fluid will start but isnt getting fuel from the injectors they won’t spray
 

·
Registered
Joined
·
3 Posts
Check the NATS indicator light. Up on the dash on the driver side, under the front of the windshield.. when you turn the key to start does the light stay on solid?
 

·
Registered
Joined
·
3 Posts
Just for shits and giggles, close the trunk, hood, doors.. and lock with the key fob.. then unlock the driver's door with the key. Then lock it. Then unlock the car with the key fob.. then get in and try it.. before I asked for help, my car didn't start for 2 weeks. I replaced a bunch of stuff. Then realized I hadn't used the key or fob in weeks. Car was on jackstands, windows were down. And battery was continually unplugged while it sat in my garage... So I came and went as I pleased.. once I activated and deactivated with key and\fob.. started right up.. had same symptoms.. everything worked. But stopped at the injectors.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
The security system seems to be fine the light on the dash goes off when turned on and after finding a different scan tool I got the car to tell me it’s got a po505 code and now getting that handled to see if that fixes the problem
 
1 - 7 of 7 Posts
Top