Infiniti G20 Nissan Primera Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
320 Posts
Discussion Starter #1
Hey all, i installed a new transmission, clutch, axles in my 95 g20. Transmission was a 96 LSD transmission (no 5th gear pop out)

I noticed i put the clutch bracket in the 2nd set of holes (closer to the firewall) and my clutch is much more 'on/off' than it used to be before.

Anyway, after a long and arduous process i got the car back together, only to realize that 5th gear randomly works or doesn't work (it feels like its in gear, but you let out the clutch and nothing happens or it lightly grinds) Then after about 100 miles my abs light has come on.

All other gears work fine and 5th gear doesn't 'pop out' or anything, its just really random about going into gear (maybe 1 in 3 times it goes in properly)

any ideas? I'm hoping maybe i just need to put the clutch cable bracket back to where it was originally?


P.S. i have noticed today (2nd week of driving, only about 70 miles on car since clutch job, that first is a little notchy sometimes...this leads me to believe it is the clutch cable...does that sound right?)
 

·
"says here on your chart"
Joined
·
4,607 Posts
I know that when i had 5th gear pop out, it used to pop out while i was driving, but then after a while, it would just not go in. i would push on the shifter up into fifth and nothing, it would stay in nuetral. Not sure if this is what you are experiencing.....and for the abs light, prob an abs wheel sensor.
 

·
Registered
Joined
·
320 Posts
Discussion Starter #3
naw, mines not popping out, it just wont go in gear..it'll stay there fine:)
 
1 - 3 of 3 Posts
Top