Infiniti G20 Nissan Primera Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Where are they located?
How many are there?

My ABS light comes on when I put it in drive and start to move. I have new pads.rotors,lines and fluid. The light was on before. I remember someone posted about checking under the hood along side the passenger side fender for the sensors. I couldn't find that post...

The pedal is tight but when I have to make a sudden stop it doesn't activate like it should.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #2 ·
I know someone has the right answer...

Come on people.
 

·
Registered
Joined
·
1,566 Posts
the ABS sensor is fitted to teh brake caliper. If you remove the road wheel, youll see the brake line and there will also be another what looks like a rubber brake line. This is the ABS wire and should be handled carefully. If you follow it, it goes into the caliper and thats where the sensor is. This is the same on all four corners.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #4 ·
P11GT said:
the ABS sensor is fitted to teh brake caliper. If you remove the road wheel, youll see the brake line and there will also be another what looks like a rubber brake line. This is the ABS wire and should be handled carefully. If you follow it, it goes into the caliper and thats where the sensor is. This is the same on all four corners.

I also believe that there are sensors under the hood and I read that they sometimes go bad. Just have to have the scan tool run on it to see whats really up
 

·
Registered
Joined
·
1,566 Posts
you need to undo the 12mm bolt (i think its 12 anyways) then have a look at the end of the sensor. Youll see that the tip of it is flat and has a tiny indentation on it. You need to use like a small hole punch and tap it out with a hammer. If its broken anyways, just smack it!
 
1 - 6 of 6 Posts
Top