Infiniti G20 Nissan Primera Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
259 Posts
Discussion Starter #1
I took the battery tray out and found there is a AC line right above the engine mount (transmission side). Looks like I have to push the line aside to move the mount out. The AC line does not seem to be too flexible. Is that the right way to take the mount out? I have a 94 Auto. Thanks.
 

·
Registered
Joined
·
17 Posts
cxqiu said:
I took the battery tray out and found there is a AC line right above the engine mount (transmission side). Looks like I have to push the line aside to move the mount out. The AC line does not seem to be too flexible. Is that the right way to take the mount out? I have a 94 Auto. Thanks.
I did my tranny mount just a few months ago and mine was just under my battery tray?
 

·
Registered
Joined
·
1,675 Posts
... I don't think that's an AC hose... give me a sec to check the FSM
k, I didn't find it maybe someone else can chime in, all I know is that I simply bolted that sucker in when I had to and I have a 93
 

·
Registered
Joined
·
259 Posts
Discussion Starter #4
slwprstyle, you are right it is right under the battery tray and running over the top of the mount.

gomd2, I'm pretty sure it is the low port AC alum. line with a rubber cover. It is running from the firewall to the front of the car on mine. Manual g20 might have different layout.

Bump for clarification!
 

·
The Emo Kid.
Joined
·
6,673 Posts
ok heres what i had to do:

this is the line:


get a wrench on the bolts you need to get out, get a sturdy bar of some sort thats a few feet long, rest it ABOVE the A/C line on the metal of the engine bay, and pry the wrench. (set the wrench at an angle so you wont hit the A/C line) this is how i did all bolts on that mount.
 

·
Registered
Joined
·
259 Posts
Discussion Starter #6
Thanks for all the info. I just got back to the computer after spending about 5 hours in the garage replacing the mounts. Took the car out for a test drive. It feels much better. It is not hard, but aligning all the bolts with the new mounts apparently takes lots of patience. I bought 3 sotck mounts from everythingg20.com. The old transmission side one is in worst condition with its center part totally separated. The driver side one is in bad condition too. The one near the firewall seems in ok condition. but its center hole is not in the same position as the new one.
 
1 - 6 of 6 Posts
Top