Infiniti G20 Nissan Primera Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Ok, minor problem. I recently finished installing the rest of my system in my car, and i pulled the seats out to pull the carpet up to install dynamat in my p11. But when you pull the seats out you hafta disconnect harnesses, which i know for a fact connect to the SRS in the seats.

What my question is, since I have done that, my Air Bag light flashes and I'm wondering what i need to do to fix it? Did temporarily dissconnecting the harnesses mess with the SRS computer under the center console? Does it need to be reset? Is there anything I can do without taking my car to the dealership? Help!!!
 

·
Registered
Joined
·
664 Posts
Here's a fix!!!! Good to know too:

I did the exact same thing when I removed all that mess from my trunk. I put my fullrange amp under the passenger seat, started the car up, checked for ground loop....and got banged with a stuck air bag code.

My brother is a service tech for a lincoln mercury dealership. He KNOWS (odd) that the mercury villager has Nissan electronics (no clue why!). Anyway - long story short...the same "trick" to clear codes on a villager WORKED for my 99 G20. Here's what you do.

Turn the car ignition to the "ON" position and hit the driver pin switch (that triggers the dome light) 5 times...

THAT'S IT! good luck...ne ?s just ask
 

·
Registered
Joined
·
59 Posts
try disconecting the negative wire off the battery for 10 seconds...that works alot on most cars....your air bag light will not come on if you leave the key out of the ignition, take the seat out put it back in then put the key in, if you put the key in before you plug the airbag in the light will stay on
 
1 - 6 of 6 Posts
Top