Infiniti G20 Nissan Primera Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
The aircon on my P11 GT was working fine, I thought I better get it recharged as part of normal maintenance (hadent been done in years) got a professional aircon place to recharge it, after which it started playing up, whenever the compressor started to cut in there would like a groaning noise and the compressor would disengage again, meaning no cold air ever got blown out. on a warm day like today (27deg C) the compressor didant even make a noise as soon as it started to engage it shut down again.

took it back to the aircon place and suggested that maybe they had put too much pressure in the system, they checked and said that the pressure was 250psi, I have no idea if this is high or not, he dropped the pressure by 50psi and it I had cold air all the way home, until I switched off the engine and restarted it when it started acting up again. (it does seem to have improved it though)

Any thoughts? what is the correct pressure anyway?

BTY on a cool evening it seems to work ok
 

·
Registered
Joined
·
663 Posts
They may have used the wrong gas for the system.
The correct pressure is a trade off, more pressure means it can remove more heat, but the ultimate temperature is not as low as when the pressure is lower.

Mike
 

·
Registered
Joined
·
9 Posts
Groaning noise... I might be wrong but usually it means liquid in small amounts is reaching the compressor, it shouldn't be possible because the compressor intake is the end of the low pressure part, you might have too much gas or waaayyy too much oil in your system, either way compressors can't take the load and varying on the amount of liquid going in, they tend to die, trying to compress liquid.
 
1 - 4 of 4 Posts
Top