Infiniti G20 Nissan Primera Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,134 Posts
Discussion Starter #1 (Edited)
Well I am fixing up the G's!
Finally my car will look good again (is what I was thinking)...
I got the parts in and gave em a look over before the ups dude left (to check for damage), everything looks good..
Wootwoot!
Well I got one car looking good (sept for paint, and the driver door a lil banged up)

Looks pretty good for my 1st time huh?
Well on to car 2 (my 1st and best G!)
I really want this one to be perfect...
I get everything off and no frame damage (lucky me)
This should be easy cake!
I get the fenders on and line them up..
Low and behold they dont line up right... I've tried to reattach the parts and line em up right but they just wont...
I thought yall might have some ideas


I'll edit this post when I have a sec to explain my ideas more in depth
 

·
Registered
Joined
·
3,940 Posts
my buddy has the same problem with the fenders. mind me askin where u bought them?
 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #3
ChickenWing said:
my buddy has the same problem with the fenders. mind me askin where u bought them?
from these guys
linky
The site says car parts wholesale, but email says usautoparts
Cheap parts and shipping, guess I shoulda known
 

·
Registered
Joined
·
1,675 Posts
Dang, those gaps are huge... try giving them a call see what's up, looks like the molding don't match up too, or is that just me>?
 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #6
nah its not just you...
I tried calling them but it doesn't look to good...

I'm thinking maybe I can file/drill down the holes so it will mive over a little bit...
This sux, its definatly the fenders cause the oem from junkyard fit perfect w/out even try'nto line it up...
Stupid aftermarket crap
 
1 - 6 of 6 Posts
Top