Infiniti G20 Nissan Primera Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter #1
ok, i have replaced the alternator twice (it was bad when i bought the car, and that alternator went bad last year) and also the battery twice.

My problem now is that the battery will die, almost over night. The brake light is on, BUT i need new brakes, and the battery lights and ABS lights are not on. I have been resorting to unhooking the negative cable when i go to work and when i get home, if the car is going to sit for a while. I replaced the negative battery cable a month ago or so.

It just started doing this maybe in November. Also, it has been below 30 degrees for about 3 weeks now. any ideas? i did a search and found some interesting suggestions, and i am going to get the battery and alternator checked tomorrow. there is some sort of excess drainage coming from somewhere....

maybe the factory security system causing an excess drain?
 

·
Registered
Joined
·
462 Posts
For brake light, make sure you have brake fluid! In g20 brake light should not come on unless there is electrical short or low fluid. This is not a low on brake pad light from my understanding, although I might be off on this one!
Also as far as drainage, I think you have a short somewhere. Make sure radio is off, and to A/C is off as well.
 

·
Registered
Joined
·
111 Posts
Discussion Starter #3
yeah, the fluid is low, plus i bought the car with 103K miles and it now has 138K, so i am guessing brakes need replacing, no biggie.

The thing is, that the battery drainage started over a year after i bought the car. It never did this before. I have no radio (just an inverter and a portable cd/MP3 player..save my money for camera lenses:) ) so that isnt the problem... i guess i will find out more tomorrow when i have the alternator and battery checked..oh it is a walbog's battery..long story but has free replacement. I also maybe should use my Interstate battery instead....
 

·
P10 FTMFW!!!
Joined
·
2,489 Posts
did you wire in anything yourself that has a constant power source? if so, rewire it to an ignition only circuit so the power is cut once you turn off the car.
 

·
Registered
Joined
·
1,118 Posts
^ +1
 

·
Registered
Joined
·
111 Posts
Discussion Starter #6
the only thing that has direct power is my rear foglamp, but it has a relay and a fuse. Plus i did that a year and a half ago. nothing new i have done to the car... i wonder what would cause it suddenly to discharge the battery. the alternator belt is on tight, all the spark plug wires and distributor wires are all good...

it did start happening after someone backed into my car and cracked the rear tailight...there is a small hole in the turn signal lens. i wonder if water gets into there and may have caused something to short or something.. that is the only thing i can think of that would cause this all of a sudden.

keep the ideas coming though:)
 

·
Registered
Joined
·
430 Posts
put a toster on the batery (not real toaster batery tester) and watch for a drain DO NOT LOAD TEST WHILE DOING THIS!!! if there is one take a multi metre and go to random contacts and switches. there might be a relay stuck somwhere. search for anything that can stay on. the turn signal is operated from a unit inside the car all switces are in there if that was the problem your turn signal wouldnt work at all and the short would be inside the cabin. something is on or shorting two alternators and a battery it doesnt make sense that the battery or alternator is bad but check thos as well. after looking if still nothing then you may load tes the battery and if it drains quickly problem is battery with engine running run same test if car dies and or sputters bad the alternator is bad. also is the car hard to get out of gear? check brake lights there ,may be a short in there. one reason why the brake light could be on. edit: i had this happen to my car problem was the alternators were all grounded directly to the starter.
 

·
Registered
Joined
·
111 Posts
Discussion Starter #8
well, the battery is getting charged from the alternator. The battery was dead the other night and i got a jump. I drove the car home (about 5 miles) and unhooked the battery. It started right up yesterday, so it is getting a charge. i bet it could be a relay somewhere. i had my ABS pump relay go bad (it was stuck open) a few years ago. just wierd it would start draining all of a sudden. Oh and i need my pads changed. At highway speeds when braking, i can feel they need changed..
 

·
Registered
Joined
·
430 Posts
yeah if the battery is fine when its diconected there is a drain somewhere something is one the only hard part is finding out what. i know of a tool that when hooke in through the obd system this included obdI it will test all the relays and tell you if one is not functional. im not sure but i believe the genisys does this too.
 
1 - 9 of 9 Posts
Top