Infiniti G20 Nissan Primera Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
233 Posts
If the battery is toast but you got the engine started by jumper cables or? Then yes, the alternator could be working so hard to charge the dead battery that it actually makes a whining noise.
 

·
Registered
Joined
·
579 Posts
Batteries with low voltage can cause mad different problems. It may sound different b/c the fuel pump isn't getting the voltage it needs and the car may be running lean. Or the ignition isn't getting the voltage it needs and you could be getting spark knock.
 

·
Registered
Joined
·
2,120 Posts
G20-tech said:
Batteries with low voltage can cause mad different problems.
What is considered low voltage? I am having the infamous bad alternator problems (battery and brake lights on) but also when I hit the brakes the tach and speedo drop to zero then spike back to normal.

My battery with car off reads at around 12.3 volts. When car starts, it does not read over 12.9. I aslo have a meter that plugs into cigarette lighter that reads between 15.4 and 15.9 (12v) then it will read 16.0 (24v) WTF? It ramdomly jumps from the 15.4 to 15.9 then 16.0.
 

·
Registered
Joined
·
429 Posts
Hmmm

I was driving home from work and noticed that when I role my Windows up they go up fater if I have my foot on the gas. Also when I start the car everything is dim but as soon as I give it gas it all lights up and stays lit. When I brake I dont see a visable diffrence in anything except the clock (not bad thou)....

What are these signs off? I was just going to go get a Optima and hope it was fixed :)
 
1 - 5 of 5 Posts
Top