Infiniti G20 Nissan Primera Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1,572 Posts
Discussion Starter · #1 ·
So I randomly had my cel pop on about a week ago, used a scan tool and got p0135 (o2 sensor upstream). I replaced the upstream o2 sensor with a brand new oem one and the code comes right back on. Every other time or so I scan it the code for the rear o2 sensor comes on (p0141), and that sensor was just replaced not long ago. Car is an 01 p11 5mt, only mods are a header and downpipe and I extended the rear 02 sensor so I wouldn't pop a code, no major exhaust leaks. This has been fine for the last 6-7 months, no codes until recently.

Anyways, this is very frustrating as its killing my mpg's. What should I check from here?
 

·
Premium Member
Joined
·
1,103 Posts
It can take sometimes as much as 300-500 miles for an obd ecu to fully cycle and to clear the code. Since getting the car on an obd reader that can show you the voltage fluctuations (through the cars diagnostic port), I would use a multimeter to check that you have constant voltage through the hot wire and continuity to the ground.

The simple solution would be the o2 sensor you bought is defective or damaged, but that's a quick to jump to decision in my book until you check out the other stuff first.
 

·
Registered
Joined
·
69 Posts
So I randomly had my cel pop on about a week ago, used a scan tool and got p0135 (o2 sensor upstream). I replaced the upstream o2 sensor with a brand new oem one and the code comes right back on. Every other time or so I scan it the code for the rear o2 sensor comes on (p0141), and that sensor was just replaced not long ago. Car is an 01 p11 5mt, only mods are a header and downpipe and I extended the rear 02 sensor so I wouldn't pop a code, no major exhaust leaks. This has been fine for the last 6-7 months, no codes until recently.

Anyways, this is very frustrating as its killing my mpg's. What should I check from here?
May I ask how you 'extended' the rear oxygen sensor?
 

·
Registered
Joined
·
1,892 Posts
Did you extend the body harness or the harness of the o2 sensor itself?
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top