Infiniti G20 Nissan Primera Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter #1
Car is registered, drove for 300 miles. Now questions

Hey guys, I picked up a 94 P10 with 126500 miles automatic last week. I finally got it registered and drove it 200 miles back here to CT. I have 2 weeks to get the car back into good running shape for my gf. Here are the problems I have

When I start the engine, the valve area would start to make a ticking noise. From teh inside it is not that noticeable, but from the outside you can definitely hear it. When I start the rev the car, teh ticking noise increases too. Other than the valves, another noise would come up. It sounds like a squeeking noise from the belt/valves area. And the last noise i have is when i am at highway speed. Most of the time I would hear a "woooo" noise. I only get the noise when i am above like 40 or 50mph. It happens 99% of the time, but soemtimes it doesn't happen.

That's all for noises

As for how the car drives. The car is definitely down on power. Although the car can reach 6500 rpm with no problem, but it sure does takes its time. When I gun it, it will climb up the RPM slowly. The car is very very sluggish. Another thing I notice is that the power delivery is VERY VERY weird. Instead of climbing up the powerband consistantly, I can feel the engine make power for like 300 RPM, then it stops, then goes, then stops again. Although the engine never stops spinning, but i can feel the power is going that way. What can cause that?

As for the transmission, i flushed out the fluid. Now the fluid is okay, but i do get slips occasionally between 2nd and 3rd gear from time to time. Is there an adjustm,ent i can do to fix it?

Sorry for the long post, but i seriously need some help. Thanks
 

·
Registered
Joined
·
13,195 Posts
94 g20

I hope you bought it for a song.. because it sounds like you need a new tranny! The 94 up G's tranny craps out at around 120K. and the new one will cost you over $2K!!!!!

...the other stuff doesn't sound so good either... did you get the car off ebay without looking at it first or what?
 

·
Registered
Joined
·
218 Posts
Since the car is down on power, I'd suggest that you do a compression and leakdown test to make sure the internals are up to snuff. If they are, you need to change your plugs, check your timing, change your air filter, etc. If it still feels like it's sluggish, it might just be the fact that it's an auto tranny G20.

Did you check this car out at all before you bought it? Have you had emissions done? If so, did it pass?
 

·
Registered
Joined
·
175 Posts
Discussion Starter #4
I changed the plugs and wires and the air filter. Car is running much better. Only tune up parts i have to do is timing, distributor cap and rotor
 

·
Premium Member
Joined
·
11,383 Posts
milage isnt bad, I get about 28 with mods....I used to get about 30 without. Check your PVC valve as well.
 

·
Registered
Joined
·
13,195 Posts
mileage will vary

mileage varies due to all sorts of conditions like:

- Altitude (higher altitude means better gas mileage)
- lead foot (duh!)
- tires (snow tires hinder gas mileage - wider tires do too, underinflated/overinflated make a difference too)
- outside temp. (colder means worse mileage)

My winter mileage is about 21mpg overall average
My highway only mileage is about 30mph
My city only mileage in summer is about 24

Your mileage sounds pretty good....

Running the A/C takes away about 1mph in my experience.
 
1 - 8 of 8 Posts
Top