Infiniti G20 Nissan Primera Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Preface- For some time now, I've had the typical G20 issue (mine is a 2001) of having to jiggle my key to get my accessories on while the engine is running. Maybe two weeks ago while driving, my accessories all died while in use on the road and wouldn't turn back on. After I parked at grocery store, they were running fine again when I turned the car back on, so I didn't think much of it.

Drove my car fine this past Friday, didn't drive Saturday, then when I went out to start on Sunday no spark, no turn over, no dashlights, security light was off, headlights, etc turn on. Am I right to assume that my ignition switch can cause battery drain, or cut power off entirely within the car, even to non accessory items like my headlights? This is also a new battery I purchased in March. I ordered a new ignition switch and hope it fixes things, but I'm at school and unfortunately don't have a garage to diagnose if it's a solenoid or something else (and I don't wanna immediately shell out cash for a mechanic unless this doesn't work). Anybody ever have similar issues/experience same problems?
 

·
Registered
Joined
·
69 Posts
I had similar issues in my '99 G20 - whenever I hit a bad enough bump in the road, my electronics would flicker. Thought nothing of it until the car wouldn't start one day. Checked my cables and the negative terminal was lose (not off, just loose). I would check the terminals. Also I've seen cars have issues starting just because the key was super worn out, so might try getting a new key made from Home Depot. I've bought Infiniti blanks from eBay and had them cut at Home Depot and they work just fine.
 
1 - 3 of 3 Posts
Top