Infiniti G20 Nissan Primera Forum banner
21 - 21 of 21 Posts

·
Registered
Joined
·
1 Posts
Sorry I haven't updated this, but believe it or not I JUST got around to doing the revolution sensor change this morning. And BUDDY I wish I did more research! I took pics during the process and this did help resolve my issue. I shift better and the car over all acts better.

I took the tire off to make this easier. I jacked up the G20 high up in the air for easier access.


The Revolution Sensor is located right behind the Driver side axle space is TIGHT. It is held on by a 10mm bolt.


Can you see it?
Warning!!!! READ THIS!!!
BEFORE YOU REMOVE THE SENSOR, MAKE SURE YOU HAVE A RAG OR SHOP TOWEL TO PLUG THE SENSOR HOLE AS SOON AS YOU PULL IT OUT!!! OR YOU'LL TAKE A TRANSMISSION FLUID FACIAL BATH LIKE I DID!!!



Top side: take the air intake off and this is the view look from the engine bay. The Sensor connector is easy as pie to disconnect it is the BROWN connector, there is a plastic plug holding the connector down that you need to pop off with something before you can remove the sensor completely. When you follow the wire down to where it plugs into the tranny there is another 10mm bolt that kind of holds the wire in place. you don't have to take it all the way out just loosen it to take the old Sensor wire off and put the new one on.


New Revolution Sensor vs the old one.


Here is the Shop towel plugging the Sensor hole I was talking about.
Do you still have the images you posted? They're not showing up and I could really use them to guide me. Thanks!
 
21 - 21 of 21 Posts
Top