Infiniti G20 Nissan Primera Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter #1
im having some serious clearance issues with my tires and suspension

the suspension is all stock and im not sure if it is shot or not (its a 92 g20 with about 154k on it)...i live in so cal, but i go to school in nor cal, so i get some serious driving in when i come down to visit and back to school...[which isnt often...maybe like once every two/three months]...

the thing is that theres almost no room between my tires and the third/upper link on the suspension...and thats for all 4 tires...and by no room i mean...i cant even fit my finger inbetween...now im not sure if thats normal, but its annoying...especially on those long drives....i can litterally feel the tires bouncing off the upper link and the the road...

anyone have any ideas what might be going on or if that is perfectly normal??? :zoinks:


also...i noticed that the rear makes a very anoying squeak every time i go over speed bumps...and it kinda bounces a little [like 2 seconds and then stops]...and im only going like 10mph at the most....would that be a shotty suspension :angry: ...or me just being picky?? :p
 

·
Registered
Joined
·
1,206 Posts
What size of wheels and tires are you running?
 

·
Registered
Joined
·
233 Posts
Discussion Starter #3
i think theyre 195/60/15...or maybe 195/55/15....but im about 98% positive its the first one
 

·
Registered
Joined
·
233 Posts
Discussion Starter #4
**BUMP**

i have some OZ Rally wheels...with 195/60/15 tires...

anyone have any suggestions as to why my tires are practically rubbing on the third/upper link?
 

·
Registered
Joined
·
1,206 Posts
I think its the combination of a tall tire and a wheel with too high an offset. You might try some spacers or just get a new wheel/tire package.
 

·
Registered
Joined
·
233 Posts
Discussion Starter #6
could i or should i just use the same wheels just get thinner tires?
 

·
Registered
Joined
·
1,206 Posts
I would start out with spacers. You could pick up some cheapies from an auto part store , or even use some washers just to see if it fixes the problem. If they work then you can get nice ones with longer studs.
 

·
Registered
Joined
·
233 Posts
Discussion Starter #9
And where would i put the spacers?...(im a newbie when it comes to suspension)

and what tire sizes should i use then...if the ones i have dont seem too fit
 

·
uruG 02G
Joined
·
7,417 Posts
paNX2- you buy those H&R's from Option Imports? Only ask because their site says the spacers for the G20 are 4x100..
 

·
Registered
Joined
·
1,206 Posts
I was just using that as an example to show him what the spacers are.

I do have a set of them on my SE-R, but I just picked that website b/c it came up on google first.
 

·
Registered
Joined
·
233 Posts
Discussion Starter #14
sorry for late response...havent had a chance to get online for a while...i went to san diego for the weekend....anyways...yeah

...so ill try the spacers as soon as i get a chance...probly tomorrow...and let you all know if that fixes anything with the tire fitment...

as for my other problem...about whether or not my suspension is shot...the thing is that whenever i have two passengers in the back the car scrapes (bottoms out?) whenever i hit any dip or bump or even when i make sharp/long curve turns....so i cant seem to determine what the hell is going on there...

any ideas or suggestions are appreciated
 

·
Registered
Joined
·
233 Posts
Discussion Starter #15
BTW...im guessing 5mm spacers would be just fine to run....[i did a quick forum search on wheel spacers and it seems that 5mm is good for standard studs]
 

·
Registered
Joined
·
233 Posts
Discussion Starter #17
i looked at the shocks and one of them seems to be missing that rubber boot thing...and the other is kinda hard to see since the tire is block most of the view...ill check them out once i get the spacer in
 

·
uruG 02G
Joined
·
7,417 Posts
The scraping/bottoming out actually sounds like your springs, not shocks, as the shocks are not load bearring, the springs hold the car up, not the shocks. If they are the original springs on a 92 G20, it's possible that they are shot and "sagging" after 15 years of holding up the weight of the car... but the sagging is not caused by the shocks.
 

·
Registered
Joined
·
233 Posts
Discussion Starter #19
i kinda had a feeling it was the springs cuz i can somewhat feel the car swaying back and forth in the rear while doing the long drives on the highway...and especially on the long curves i would feel a lot of body roll too....

im thinking about getting some Tein S.Techs for the holidays :cheeky: ...if the scraping still occurs then ill throw on some KYB GR-2's...and then all ill need is front and rear strut bars and my suspension mods will be done....

...then maybe i can look into dropping that T28 in that ive been postponing for about a year and a half now... :naughty:
 
1 - 20 of 24 Posts
Top