Infiniti G20 Nissan Primera Forum banner

1 - 8 of 8 Posts

·
CH0DEmobile
Joined
·
3,202 Posts
Discussion Starter #1
Ok, so, as the title states, I've got a nice clunk coming from the right front (passenger) wheel when I shift gears hard, or left on/off the gas hard in gear. It ONLY does it under engine load, not during braking. I took everything apart today to make sure nothing was loose, but the clunk is still there. I thiiiiink it's my CV, but I just replaced it a few months ago with a brand new axle. Any other thoughts on what it might be? It's driving me nuts. :zoinks:
 

·
CH0DEmobile
Joined
·
3,202 Posts
Discussion Starter #3
Damn, you know, I didn't even think of that. Mine are shot to hell, and that's probably what's clunking around. Thanks man.
 

·
Registered
Joined
·
2,522 Posts
there is information about filling in your own motor mounts on
here. that would solve the problem only if its the insulator thats
gone. if its the bracket thats cracked then you'll need new ones.

and its def not your CV joint for what your describing. bad CV joints click
when turning. as gomd3 stated, sounds just like a motor mount issue.
 

·
Registered
Joined
·
1,675 Posts
filling motor mounts has to be done right, It's kinda hard but saves you a ton of money in the end. search around, I would tell you but I feel kinda lazy to search around.
 

·
CH0DEmobile
Joined
·
3,202 Posts
Discussion Starter #7
njprimera said:
there is information about filling in your own motor mounts on
here. that would solve the problem only if its the insulator thats
gone. if its the bracket thats cracked then you'll need new ones.

and its def not your CV joint for what your describing. bad CV joints click
when turning. as gomd3 stated, sounds just like a motor mount issue.
yep, that's true for most CV joint failures. usually, the outer joint is the one that fails, which leads to the clicking during turning. but if you've got a bad inner joint, you usually won't hear it except under load, when going over bumps, or sometimes it can be felt as a vibration. but, yeah, i'm sure now that it's a mount, idk how i overlooked that when i was trying to figure out what the problem was.
 
1 - 8 of 8 Posts
Top