Infiniti G20 Nissan Primera Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello, I keep getting this “p1320” code and it says “Condenser IG coil” and as I know my Infiniti g20 2000 Doesn’t have a Ignition condenser ( the little box that’s $7). My car won’t even turn on after changing the knock sensor(Which was another code I got) but it cranks. But I think this code(p1320) is what causing my car not to start but I can’t seem to figure it out since it says condenser ig coil and my car doesn’t have a ignition condenser. Could it be my ignition coils that’s causing my car not to start?

Any advice is helpful!
 

·
Registered
Joined
·
20,795 Posts
Is this your only code? Or do you have P0340 too?

Your car has a condenser, it is just inside the distributor unit.

I've seen a lot of dead p11s recently on the internets. Usually a new or good distributor is what you need to get going again. Aftermarket distributors aren't great.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Is this your only code? Or do you have P0340 too?

Your car has a condenser, it is just inside the distributor unit.

I've seen a lot of dead p11s recently on the internets. Usually a new or good distributor is what you need to get going again. Aftermarket distributors aren't great.

I had a knock sensor, o2 sensor code, change them both, and after I was changing my oil my car shut off, it cranks but doesn’t turn on. Both codes seemed to be gone. I just have P1320 code, I struggled to find the condenser, I’ll see tomorrow if i can find it again inside the distributor. Thanks for the reply, I would love to drive it again ?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Is this your only code? Or do you have P0340 too?

Your car has a condenser, it is just inside the distributor unit.

I've seen a lot of dead p11s recently on the internets. Usually a new or good distributor is what you need to get going again. Aftermarket distributors aren't great.

Real quick question, when you say inside the distributor unit you mean inside this ?

https://www.google.com/aclk?sa=l&ai=DChcSEwjIwuWd0pPmAhVW3IYKHbx2Az8YABADGgJ2dQ&sig=AOD64_1kTmm2PajaIzLz7169tYw-Mj1uVQ&adurl&ctype=5&ved=2ahUKEwioztmd0pPmAhVElFkKHY87AY8Qwg96BAgBEC4

Also this condenser you’ll find inside the distributor ?

https://www.google.com/aclk?sa=l&ai=DChcSEwjBl_fN0ZPmAhUah4YKHQ_qB4UYABABGgJ2dQ&sig=AOD64_2OV569MsI1QLg_utDMBZaK2hRjgw&adurl&ctype=5&ved=2ahUKEwiUqOXN0ZPmAhWQ1lkKHe05C04Qwg96BAgBECs

Sorry, just don’t want to take forever trying to look for it like I did this week
 

·
Premium Member
Joined
·
1,098 Posts
1320 is usually due to a distributor going out, the ecu will throw this code if the harness plugs attached to the distributor are not connected well, or if you have a short in your wiring. It will also flag the code if the distributor is not sending .3v to pin 35 of the ecu, or appx 13v to pin 36 of the ecu, when the car is running or idling.

Last, sounds like you took some things apart when you replaced the knock sensor, if the distributor was adjusted in anyway, too much +/-, the car will have a difficult time starting.
 
1 - 5 of 5 Posts
Top