Infiniti G20 Nissan Primera Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
After 3 weeks of no driving, my car is finally up and running. The start died on me that's why I haven't been rollin". Anyhow, I was wondering if anyone can tell me how to make my car run better right off of cold starts. Once the engine is warmed up, it's flawless. If I just start to drive it without warming it up--it just seems a sluggish. I've put in the bosch 4-prong spark plugs and cleaned out the EGR stuff, but I don't know. It's not as smooth as it used to be. I have 105K miles.
 

·
G20.net Retiree
Joined
·
833 Posts
What type of climate are we talking about here?


Right now its still cold here in NJ so starting requires a bit of warmup to get everything nice and warm and ready to go.


In warmer weather though I've never experienced any sluggishness off the start.
 

·
G20.net Founder
Joined
·
2,110 Posts
JKdonger said:
I've put in the bosch 4-prong spark plugs and cleaned out the EGR stuff, but I don't know. It's not as smooth as it used to be. I have 105K miles.
Ditch those plugs! We dyno'd a 200sx SE-R a couple years ago and they cost the guy 4 hp! We even replaced them with old used plugs. You should always wait a couple minutes before you start hauling around. Give everything a chance to come up to temp. If you're in a real rush, start your car earlier. :p
 

·
Registered
Joined
·
49 Posts
Discussion Starter #4
Well I guess you're right about those damn plugs, I keep on reading that you should stick to OEM NGK plugs. As for the climate here in Oregon, pretty much the same as the Jersey in the winter--cold,rain, and snow. Much more cold and rain though.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #6
Well, actually I did feel my G pick up better when I first put them in, but as its turning out--they are not lasting as long. I am gonna stick to the OEM plugs and wires.
 

·
G20.net Founder
Joined
·
2,110 Posts
webplayerxvii said:
So the Bosch 4-prong spark plugs suck then?

I put them in my g20 and the work fine and it seems to get more pickup.
You probably would have felt the pickup with any new plugs you would have put in. The SR20DE doesn't like those gimmicky plugs. :-\
 

·
Registered
Joined
·
102 Posts
this may sound alittle odd but when i start my car in the cold i feel like it has more power..i dunno... in your situation i would just let it warm up couple minutes before you go cruisin... g/l
 

·
G20 Junkee
Joined
·
2,343 Posts
My car too

...............is extremely sluggish in the cold although I know there is something else wrong with it causing it to perform like this. If I dont drive my car for say 3 days and the weather is cold my car will rotate but not fire. I have to hold my foot on the pedal until it fires and this takes about 30secs. of cranking. Then when she finally fires up it blows black smoke!!!

Go figure:evil:
 

·
Registered
Joined
·
49 Posts
Discussion Starter #10
You know what funny about this cold start issue of mine--after I replaced my dead starter, it seemed to cure most of my starting issues. I know the other source of my probs too, I need to get rid of those piece of shit BOSCH plugs/ wires and go back to OEM plug and wires. As soon as I can come up with the flow, I will get it done--$$$$ always the issue.
 
1 - 10 of 10 Posts
Top