Infiniti G20 Nissan Primera Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
If I honk the horn for more than a moment my ABS light turns on. Turning off the car clears the light until the next time I honk the horn.

I checked the ABS code using the self-diagnosis procedure in the FSM. (Ground terminal 4 of the Consult connector.) The code I get (2-1) indicates a problem with the Front Right speed sensor. I cleared the code from memory and started the car and tested again. The ABS light is off and there is no error code in memory.

Now I start the car again and honk the horn. The ABS light comes on. I run the self-diagnosis procedure again and code 2-1 is back!

Note that it isn't necessary to drive the car to observe this behavior. If I start the car and just sit in the driveway and honk the horn then the ABS light turns on and code 2-1 is stored in memory.

Is honking the horn somehow messing with the ABS computer? Before I start chasing bad grounds, etc I thought I would ask here is anyone else has experienced something like this.

Thanks!
 

·
Registered
Joined
·
95 Posts
Sounds like bad grounds in the engine compartment. There are 2 ground points each 10mm bolts right next to the abs pump and horns on the belt side of the engine. I would sand/clean them until they shine. This cleared up alot of random abs issues for me.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
Thanks for the suggestion. I cleaned both ground points (one on the right inner fender and the other next to the hood switch) but it didn't change this odd behavior. I'm starting to wonder if maybe there is a problem with the battery and/or alternator. If I move the power seat, the ABS light also comes on. The battery is 5 years old - maybe it is time for a replacement?
 

·
Registered
Joined
·
1 Posts
My 2006 GTO's battery went dead replaced it new red top gel found later still had a drain on it once or twice I had the abs light flash just for a split second while starting it before the battery change then no problem but still had the drain going on used a delton gel charger no problem but forgot it unhooked for maybe 4-5 days and battery dead again charged it full again turned the key on waited till the belt warning dinger stopped and the abs warning came on again played traction control button because with the abs warning on it would not turn on or off. That's all fun so I turned the key back off waited for a bit turned it back on and while the belt warning is going off I decided to see if the trac control button was showing on or off by pressing it several times before the dinger stopped and low and behold the traction control button was turning the dash light on and off for it no problem and guess what this time no abs warning but then just for some reason out of the blue I decided to tap the horn and got the same thing you did lolll the abs light came back on tried turning the key on and off several times more without starting the car like above and same thing, did you ever get yours fixed or find out how the hell that happened or was related to something. Thanks for your time, Gman2
 
1 - 4 of 4 Posts
Top