Infiniti G20 Nissan Primera Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter #1
so my question is: is the little defroster logo supposed to light up when the lights are turned on? and second is the little dot i can see next to it supposed light up when turned on? third if they are, mine don't do either, can i replace the lights or do i need a new button?
 

·
Registered
Joined
·
200 Posts
Discussion Starter #3
well i got my dash out doing a stereo/alarm install and it looks like the button can just come off. so i was thinkin if i can't replace the lights i'd have to just buy a new button.
 

·
Registered
Joined
·
329 Posts
New button should do the trick. Have you tried taking the actual button apart? Doesn't it just snap open? There should be (most likely) a small bulb inside that thing.
 

·
Registered
Joined
·
906 Posts
Yes, there are two bulbs in the defrost button. One lights up with the dash lights, and the other lights up when you turn it on. Seems like ALL the control button bulbs last only a few months.
 

·
Used to own a P10
Joined
·
5,396 Posts
satanshollow said:
Seems like ALL the control button bulbs last only a few months.
Really? My orange defrost indicator and all the lights in my blue light button are still going strong after 14 years.
 

·
Registered
Joined
·
906 Posts
The orange button works, but the HVAC bulbs and various other bulbs burn out pretty quickly. I don't even know if the fog light switch is supposed to light up with the dash lights?
 

·
Used to own a P10
Joined
·
5,396 Posts
^^^ My bulbs are about half burned out and half still working.
 

·
Registered
Joined
·
200 Posts
Discussion Starter #10
mine are all burned out. the only ones that work are the green ones with the selector and the locks button in the center console.
 
1 - 10 of 10 Posts
Top