Infiniti G20 Nissan Primera Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
This morning I got in my car turned it on, engine turned over and caught, drove to where i needed to go (about 5 minutes away or so), turned my car off, was gone for like less than 20 minutes altogether. When I got into my car and tried start my car the engine would not turn over. dash lights come on. stereo and temp control and fan come on but when I go to crank it up, nothing. Called my brother, he came over got the jumper cables out, still would not turn over. checked most of the fuses in the fuse box by the battery, but none that we checked where burnt out, there are 6 green square fuses and one big for the battery that we did not know how to check.

Car is a Naturally aspirated, automatic transmission, 2002 g20 about 128,000 miles on it. thanks in advance for any help.

Edit: Replaced some fuses, not the 80 Amp or 100 amp ones but all the JCase 30 amp and 40 amp fuses in the fuse box next to the battery.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
I Did some more investigation and when I try to crank the engine there is a Whiring sound but there is also a brrt sound up by the firewall near the center but more towards the passenger side. It kinda sounds like the solenoid on the starter went out. but that is just a guess at this point. all the fuses look ok. Also the fuse box on the passenger side there is a buzzing sound like an electrical short, but there is nothing in that fuze box that is related to ignition or getting the car started. Is this the solenoid on the starter gone out? or is it something else? Thanks again for any help you can give.
 

·
Registered
Joined
·
391 Posts
Look up symptoms of a bad distributor, and see if it fits what you are experiencing.
Also, check your computer for codes. A OBDII scanner is necessary for that.
 

·
Registered
Joined
·
16 Posts
Sounds like it’s your starter. I’ve replaced my starter like 3 times already... take the starter off and have it tested at your local auto parts store for free.
 

·
Registered
Joined
·
10 Posts
This morning I got in my car turned it on, engine turned over and caught, drove to where i needed to go (about 5 minutes away or so), turned my car off, was gone for like less than 20 minutes altogether. When I got into my car and tried start my car the engine would not turn over. dash lights come on. stereo and temp control and fan come on but when I go to crank it up, nothing. Called my brother, he came over got the jumper cables out, still would not turn over. checked most of the fuses in the fuse box by the battery, but none that we checked where burnt out, there are 6 green square fuses and one big for the battery that we did not know how to check.

Car is a Naturally aspirated, automatic transmission, 2002 g20 about 128,000 miles on it. thanks in advance for any help.

Edit: Replaced some fuses, not the 80 Amp or 100 amp ones but all the JCase 30 amp and 40 amp fuses in the fuse box next to the battery.
Try hitting your starter with a hammer to see if that temporarily engages your starter.
 

·
Registered
Joined
·
427 Posts
Ivis. Nats. Stuck or worn brushes in the starter most likely. I've been through a million almost of these starters in the scrap yard and everywhere nation wide and never 1 time seen a failed starter solenoid in a sr20. Seen lots of stuck brushes on stuff from autozone or o'Reilly's starters especially in the p11's . You can get brushes and rebuild or get a whole new starter. Take the starter out and put power to it see if it turns over. Hold it with your foot and you can see if the solenoid engages too. The buzz sound for a few seconds when key on you hear but the firewall is the TPS.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
When I replace the starter, do I need to replace the gear or whatever that the starter is attached to?
 
1 - 8 of 8 Posts
Top