Infiniti G20 Nissan Primera Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
this is really extrange: i'm driving normally and all of the sudden the clutch went down..!!

shifting gears was almost impossible!! but, when the car it still cool in the mornings i can shift well for 20 to 30 minutes. the deposit is not leaking, the clutch and preassure plate almost new.
i'm thinking, it could be the clutch pump, but these cars are strong in this area even with big up-grades like turbo...
since my car it's a turbo p11 ( primera) maybe some of you had this problem before and give some advice..
 

·
Registered
Joined
·
430 Posts
maybey there is air in the system messing up the pump as it gets warm? or maybe the throwout bearg is going bad. im not too familiar with hydrolic clutches but in the ford escape with the cable system the throw out bearing will make the pedal soft and hard to shift. bump this see what you get.
 

·
Registered
Joined
·
4,332 Posts
Seems to me that you'll need to bleed the system, if not my guess would be that's the hidraulic pump is in need of a rebuild.

Take good care of that boosted P11 ;)
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
4dollarg20 said:
maybey there is air in the system messing up the pump as it gets warm? or maybe the throwout bearg is going bad. im not too familiar with hydrolic clutches but in the ford escape with the cable system the throw out bearing will make the pedal soft and hard to shift. bump this see what you get.
could be..!!!?? thanks
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
CarloSR said:
Seems to me that you'll need to bleed the system, if not my guess would be that's the hidraulic pump is in need of a rebuild.

Take good care of that boosted P11 ;)
that's may guess! i think the pump will need to be rebuild
 

·
Registered
Joined
·
430 Posts
good luck on finding that prob. the pump is it mechanical like a power steering pump? does it whirr realy bad when pedal is depressed? if it whirs im guessing your either leaking, low, or have air in the system. if not its a good possibility that the pump is dead. i wouldnt go throwing parts at it untill you find out the actual problem.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #7 (Edited)
extrange clutch problems solved!!!

my mechanic started looking around, and he askme again about the simptoms of my p11, then he smile back at me and says: it's easy "you have 1 of the 2 bad clutch pump" for this case i you have to replace the 2 of them, or have them repaired. beacuse the old one will damage the new repaired one. ( remember the p11 uses 2 clutch pumps, 1 on the pedal and the other in the tranny) so my mechanic decided that it won't be necessary to change them, only rebild them.... when the car was finished, i went for a test. '' the clutch felt totally different" softer and more edgy the answer was: now i had "normal preassure", and the point when the car starts to move it's a little bit retarded. (used to be as soon as i started to release the pedal before it broke) pedal now feels much softer due to the greater pressure working on the clutch and preassure plate. happy ending...
 
1 - 7 of 7 Posts
Top