Infiniti G20 Nissan Primera Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,021 Posts
Discussion Starter #1
The number 1 position on my fan/AC control quit blowing air. I was looking on eBay and there is another P10 with a similar problem. Is this a fairly common problem on P10's? I'm gussing I should just do some resoldering inside the unit. Let me know if there are any other tips...:)
 

·
Registered
Joined
·
23 Posts
I also had a problem with the fan switch on my 92 G. It was the 1st 2nd and 3rd positions that did not work. What happened on mine was that the copper conductor in the switch had gotten so hot that it melted the plastic that it sits in. So when the switch turned it did not make contact. Of course this happened in the middle of winter and late at night. I took the HVAC controls out of the dash. Then pulled the switch off the push button part of the controls. Then took apart the switch (I almost lost the spring and ball bearing inside of the switch). I scraped the burnt plastic out with a knife and file and bent the copper back into shape. Then I took JB WELD and filled in the back of the copper for support. After the JB cured I lubed the moving parts and put it all back together and it has been working fine since. I forgot all about it until I read this thread. I probably should get a new switch just in case. I hope this helped. Maybe yours is something else?

-2G's
:beard:
 

·
Registered
Joined
·
431 Posts
I was without settings 1,2 & 3 last month.

It was the Blower Motor Resistor, which was maybe $30. It took me just a few minutes to replace.

BTW - Do you think a luxury car dealer like Infiniti appreciates current Infiniti owners doing their own repairs in front of the showroom?

I hope this helps.

-Don
 

·
Registered
Joined
·
20,843 Posts
DonSwier said:
...Blower Motor Resistor...
Very common problem.

DonSwier said:
BTW - Do you think a luxury car dealer like Infiniti appreciates current Infiniti owners doing their own repairs in front of the showroom?
Sounds fun, I should try it sometime.
 

·
Registered
Joined
·
46 Posts
Well, I have experienced the notorious "fan switch only works on level 4" for the last year now... Only thing is, when I did the switch to the new resistor, nothing happened. It is still messed up... :(

Upon reading 2G's post, I may just give-in and take out my entire dash so I can get the buggered up fan switch out, because that is about the only thing left to check.

I'll post back with my experience.
 

·
Registered
Joined
·
228 Posts
where is it on a P11 (1999 G20) can't find it 'blower motor resistor'??? anyone have pics of this, dont think its the same as P10..
-can't turn off the fan
-only work on one setting the fan
 

·
Registered
Joined
·
228 Posts
screw the blower motor resistor

replaced the blower motor, replaced the whole climate control unit (and filters) I still can't turn my fan off...f*ing pissed!! Can you guys turn the whole system off completely off so no air blows? I'm done spending money on this shit.! both were used
 
1 - 8 of 8 Posts
Top