Infiniti G20 Nissan Primera Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter #1
i just recently found out at my last oil change that my oil pressure switch and valvecover are leaking oil. has anyone replaced these parts? or does anyone have any advice on how difficult this would be if i did it myself? btw-where the hell is the oil pressure switch?
thanks in advance for any help
 

·
Registered
Joined
·
144 Posts
Discussion Starter #2
sorry i put this in the wrong topic
 

·
Registered
Joined
·
2,120 Posts
The valve cover gasket is a simple job to do. You can pick up the gasket set at your local dealer. It comes with the valve cover gasket and the spark plug hole gasket. Just make sure you clean off any of the old gasket material and replace the gasket material with grey gasket sealant.

You really should have a Chiltons manual (Sentra SE-R/NX2000 would be fine) or the actual FSM to do this job so that you can have the correct torque specs etc.

The oil pressure switch is a very common leaking point with the SR20DE's. It is what controls your oil switch dummy light on your dash. From what I know Nissan has redesigned this switch 3 times now, maybe more. (I know I have the part # for all three)The oil pressure switch will cost you only a few bucks, but it is quite a pain in the ASS to get to.

It is right above the power steering pump and is screwed into the lower portion of the oil filter bracket. Jack up the car. Put it on jackstands. Lay under it with your feet facing out from the front of the car and look straight up over the passenger side axle to the left of the power steering pump. It looks similiar to a O2 sensor.

Go here for information on my adventure with replacing this switch!

http://nismopc.tripod.com/oil_switch.htm
 

·
Registered
Joined
·
455 Posts
When I install my oil pressure gauge on my G20... I have to replace the stock oil pressure sensor with the new sensor for the gauge. I had a hard time getting the stock sensor off due to its design. I ended up have to go to Pepboy's check out a new stock sensor and went to the tool "special sockets" section to look for an adaptor it. Problem solved once I got the adaptor home. The old stock sensor came right off.
 
1 - 4 of 4 Posts
Top