Infiniti G20 Nissan Primera Forum banner

1 - 20 of 24 Posts

·
P10 FTMFW!!!
Joined
·
2,489 Posts
Discussion Starter #1
Hey guys, I just got some fog lights for my P10...my whip is a 93.5 and i dont think it had the wiring for them. So, now I have fog lights, and a switch, but no wiring to connect the two together. Can I just buy the wiring and the harness connector to the switch from a dealership? Or do I have to try and find it off a junker? Any suggestions?
 

·
P10 FTMFW!!!
Joined
·
2,489 Posts
Discussion Starter #3
Ok...well..where can I get the relay? Call up the dealer tomorrow maybe?
 

·
rhd specialist
Joined
·
5,685 Posts
jasezero said:
Hey guys, I just got some fog lights for my P10...my whip is a 93.5 and i dont think it had the wiring for them. So, now I have fog lights, and a switch, but no wiring to connect the two together. Can I just buy the wiring and the harness connector to the switch from a dealership? Or do I have to try and find it off a junker? Any suggestions?


if im not mistaken, the necessary wires for your fogs should be available from the main harness. months back, i pulled a set of p10 fog lights from the wrecking yard and i didn't ran any extra wires when i mounted them on my 91 (it was just plug and play), same as the factory fog light switch. i'm not sure if you have the factory touring kind or an aftermarket type, but here's what i got (off of a p10 touring)..... good luck :cheese:

 

·
P10 FTMFW!!!
Joined
·
2,489 Posts
Discussion Starter #6
Alrighty, I'm gonna make sure I dont have the relay already, i'm pretty sure I dont but it be good to check just in case. I really doubt I have the wiring there since I dont have a touring model but I'll look as well. Thanks for the tips guys.
 

·
Registered
Joined
·
597 Posts
the wiring on mine (for the foglights themselves) were taped up behind the bumper. if you take the splash guards off the bottom you should be able to see them. you can install them with the bumper cover on, but its easier to do it with the cover off. and if you have the bumper cover off then it will be easy to get at the wires and do the install
 

·
no rainguard clips...FML
Joined
·
4,132 Posts
i believe all models came wired for foglights, wheather it was a touring model or not. just like these two other fellas, you just have to undo the tape or zip tie holding the connecting harness under the bumper as well as behind the center console for the switch and it really is plug n play unless you have a jdm type (im pretty sure they have diff connectors...)

basically. no wiring needed, just gotta find em and plug em in! have fun!
 

·
P10 FTMFW!!!
Joined
·
2,489 Posts
Discussion Starter #9
Sweet, well I just bought the relay...so yeah im gonna try and get them in soon :)
 

·
P10 FTMFW!!!
Joined
·
2,489 Posts
Discussion Starter #11
Of course...hopefully it should be with the Laguna lip on as well :)
 

·
p10 guru
Joined
·
2,908 Posts
the plug for the fog light is usually taped to the bumper light harness. if you take out the 1 philips screw on the bumper light and pull it out you will find the fog plug. the plug for the switch is usually taped to the defrost or hazard plug.
 

·
P10 FTMFW!!!
Joined
·
2,489 Posts
Discussion Starter #13
Alrighty, I'll see whats there today sometime...thanks for the info guys.
 

·
P10 FTMFW!!!
Joined
·
2,489 Posts
Discussion Starter #14
Ok, so me and njprimera came to a couple oddities when looking at how to mount my fog lights today.

1) The connectors on the ends of the wires in my car are different than the connector on the fog light.

This is the connector hanging inside my bumper:



This is the connector thats on the fog light:



Its not too big of a deal but I figured all the connectors for the P10 would be the same.

2) The mouting points threw us off. It looks the two bolts for the mounting bracket at the top come through the top and drop down through this point into the bracket:



But, the bolts on the fog light bracket do not want or look like they come off:



Any suggestions?
 

·
Registered
Joined
·
1,733 Posts
jasezero said:
Ok, so me and njprimera came to a couple oddities when looking at how to mount my fog lights today.

1) The connectors on the ends of the wires in my car are different than the connector on the fog light.

This is the connector hanging inside my bumper:



This is the connector thats on the fog light:



Its not too big of a deal but I figured all the connectors for the P10 would be the same.

2) The mouting points threw us off. It looks the two bolts for the mounting bracket at the top come through the top and drop down through this point into the bracket:



But, the bolts on the fog light bracket do not want or look like they come off:



Any suggestions?
Use flower icon on camera (macro), turn off flash
 

·
P10 FTMFW!!!
Joined
·
2,489 Posts
Discussion Starter #18
Yeah sorry about that...but you can kinda get the general idea from the pics.
 

·
P10 FTMFW!!!
Joined
·
2,489 Posts
Discussion Starter #19
Ok so I'm still clueless here...the brackets definitely look like they are USDM, not JDM ones after looking at earlier threads. But I cant get the bolts detached from the bracket. I've sprayed them with PB blaster to free up some of the corrosion and everything I've tried will not get these bolts out. Plus, this whole harness thing is still bothering me.

Here are some hopefully clearer pics:







I know the harness is blurry, but I couldn't get a clearer picture of it.



What the hell is going on here?
 
1 - 20 of 24 Posts
Top