Infiniti G20 Nissan Primera Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 91 G20 and it won't start, i think it might be electrical problems but idk? I got a new battery, a new starter, new spark plugs, yet it still won't crank over. Can anyone help me?:baffled:
 

·
Registered
Joined
·
691 Posts
well it could be an alternator problem aswell.

Get a jumpstart. If the car start perfectly fine. then it's most likely the alternator
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
i did jump it, but it still wouldn't crank over. idk what it could be? i remember i got the alternater checked and they said it was fine?
 

·
Registered
Joined
·
1,675 Posts
so clear something up, is it not cranking at all like the starter doesn't make any noise? Do you hear a clicking or is the starter actually turning the engine but the engine wont start.

if the starter isn't going at all it could be the starter fusible link or relay, check these under the hood by the intake.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
my g20 does make a cranking noise when i try starting it but it won't start up, i had one of my cousin's looked at it and he said that there might be an electrical problem? he said there might be a shortage somewhere but idk? and so i thought if anyone had this problem or knows how to fix it can you let me know?
 

·
Registered
Joined
·
1,675 Posts
it's more likely than not the fuel pump, or the injectors, cheapest way to check for this is unhook the main fuel line, have a friend turn it to the on position, you know the one where the ac and dummy lights come on, and see if fuel sprays out of the hose, make sure you only do this for a second. The correct way to do it, is by hooking up a fuel pressure gauge to it and doing the other procedure. Good luck let us know.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Alright. I'll have to test the fuel line. Actually I just remembered, I would charged the battery to its fullest, crank the ignition and boom, it dies. All electrical does not work. So I decided to do another test. I turned on the headlights, juiced up the battery, and cranked it one more time. Headlights shuts off, and all electrical does not work again. So, I double checked the battery cables, and found out that the positive lead was a little worn out. I decided to cut the wire and re-wire the connection. So shortly after I was done re-wiring the positive lead, I decided to juice up the battery one more time, and turned on the headlights. Cranked again one last time..........still same problem. Everything went dead. So def. I am 95% sure its an electrical problem. If anyone has ran into this problem it would be greatly appreciated by a member of the G20 family! Lol. :D
 

·
Registered
Joined
·
188 Posts
Stranded! Don't mean to hijack, but I am stuck in a parking lot with a similar issue. Using my phone for searches, but can't post a new topic. Just changed battery posts and cleaned maf. Everything was great and car felt more responsive. 2 miles into test drive and it just died. Turn key, no lights anywhere, but battery sounds strong as it tries to crank but won't turn over. No gauges no lights can't even roll up the windows. Any ideas???
 

·
Registered
Joined
·
1,675 Posts
sounds like you have a starter relay shorting out, take it out and replace it, it's a cheap enough part by the intake like I told you...
 

·
Registered
Joined
·
514 Posts
ehhhh i hate saying this but this is in the wrong section..... seriously..... there is a maitence thread.... sry im having a bad night ....
 
1 - 14 of 14 Posts
Top