Infiniti G20 Nissan Primera Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi Guys, I just bought an infiniti G20! 1993, manual!! yesterday :) , I'm very happy, and I like to add, that this sites rules!!!

But the bad new of the car, is that I have problem shifting. it's hard to shift from neutral to 1st, and to 2nd while driving, but 3rd and 4rd and 5ft shift very well. Also, when stopped, sometimes( 80% of the time), It's hard to shift to reverse, when I try to change from neutral to reverse, it's slips(the engine accelate just like If I we're in neutral), but do not move and it grinds( scary noise, it maybe means costly repairs). is not the fluid, it seems to have enough.

need HELP PLEASE!!!
 

·
Registered
Joined
·
14 Posts
Discussion Starter #2
I would to specify, that it grinds, once I have shifted to Reverse. I'm in R position, but it grinds
 

·
Registered
Joined
·
605 Posts
My car has that reverse prob sometimes too and im not sure what causes it all i do is put it back in neutral let out the clutch then then try to put it back into reverse then it goes right in. As for the 1st and 2nd prob sounds like you just need to adjust the clutch cable.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
uhmm, the cables? I will look at it, but, I have been reading a lot. And I have found that the transmission synchronyser might be damaged, because it's hard to change in one or two gears.And because it slips sometimes(like in reverse). Can someone comfirm the problem.

Thx Mxer683 for the reply.
 

·
Registered
Joined
·
1,361 Posts
Does it slip in the forward gears also?

If not, then it sounds like the clutch cable needs to be adjusted, or the shift mechanism is worn or needs to be adjusted, or you have an internal mechanical problem in the transmission.

Attack the problem in that order.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
no, it doesn't slip in forward gears, only in R...by shift mechanism, do yo mean the clutch? can the clutch mechanism be ajusted? or is it only the clutch cables that can be ajusted? I have looked in the owner manuals of the car. And I was told that, it's can be normal, slipping problem on R....it's says that I should go from first to neutral, then Reverse...I should try, all this solutions on monday....and come with results(good I hope)....
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
Hi guys, so this is the result, the CABLE CLUTH !!, I left the car at my cousin last monday because I needed a transit plate to move it( it's a long story), but this morning, When I pressed the cluth to start the car, it broked!!!! my mechanic is putting a new one(clutch cable) this afternoon, I hope it won't have problem to shif to 1st and 2nd.... The theory in here, is that the cluth cable was loose, because it would almost broke, so does it need more resistant to switch from N TO 1, and 1 to 2, then the 3-4-5 gears? if it does, the clucth cable was the problem
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
allrighty PEOPLE!, the problem was the clutch cable, it was loose, then it broked...it's a good thing, I was scared that it could have been the clutch :) thx jjacob and Mxer
 

·
Used to own a P10
Joined
·
5,396 Posts
My G20 has been doing the slipping/grinding-in-reverse thing since new. We took it to the dealership for it when it was still under warranty and they said it's perfectly normal. Basically, it does that when it's not all the way into reverse. After it grinds, you should be able to put it all the way into reverse just fine.

I might add that we are on the original tranny. I'm not sure if we are on the original clutch cable but it doesn't really matter because it has done this forever.
 
1 - 9 of 9 Posts
Top