Infiniti G20 Nissan Primera Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
311 Posts
Discussion Starter #1 (Edited)
speaker creaklying when on

I just installed my new HU today, I pop in a cd to see if it plays. It plays alright but if I put it on mute or put the volume really low I can hear this crackly sound, Its like if you have the volume all the way up on a speaker but no song is coming out you get this crackly sound. Does anyone know what this is or can relate to?

I still have the 2 factory installed amps in.
 

·
Registered
Joined
·
450 Posts
If it did the same thing with your old HU then it's probably the amps. Are you using a scosche adapter? Make sure that you don't connect speaker level outputs from your HU to the factory amps.
 

·
Registered
Joined
·
311 Posts
Discussion Starter #6
its never done this ever until I put in the new HU.

Yes I am using a scosche adapter.

How do I bypass the amps? there an easy way to do this.
 

·
Registered
Joined
·
796 Posts
If the sound speeds up as you rev the engine then you have engine noise... Usually a sign of poor head unit grounding.
 

·
Registered
Joined
·
31 Posts
blackhawk said:
its never done this ever until I put in the new HU.

Yes I am using a scosche adapter.

How do I bypass the amps? there an easy way to do this.
Do a search for 'amp bypass'. Here's the best link:

http://www.g20.net/forum/showpost.p...87&postcount=35

Essentially you unplug both amps in the trunk and put jumper wires on the connectors (the amps stay unplugged). Pretty easy once you have the pinouts for the trunk connectors. Then you cut off the scosche gain portion of the adapter (black box) and just wire the connectors up straight to your head unit.

However, the amp bypass won't make your noise go away if you still have head unit chassis grounding issues.
 

·
Registered
Joined
·
404 Posts
blackhawk said:
its never done this ever until I put in the new HU.

Yes I am using a scosche adapter.

How do I bypass the amps? there an easy way to do this.
this is the connections for the jumper wires i got from another thread, but i can find the actual thread...
Front:
Left Positive: purple to [blue] with white stripe
Left Negative: green to blue with green stripe
Right Positive: blue to brown [ ]
Right Negative: pink to brown with white stripe

Rear:
Left Positive: [blue] to green
Left Negative: [pink] to black with green stripe
Right Positive: purple to orange
Right Negative: [green] to black with pink stripe

you also can just run wire straight from the headunit to the rear speakers. thats what i chose to do.
 

·
Registered
Joined
·
796 Posts
well that depends on if you have an issue with your headunit ground.
 

·
Registered
Joined
·
311 Posts
Discussion Starter #12
I bypassed the amps and no more crackly sound, thanks guys for your help. I also go the subs and amp for the subs in. Ill try and get some pics.
 
1 - 12 of 12 Posts
Top