Infiniti G20 Nissan Primera Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
586 Posts
Discussion Starter · #1 ·
Ok, just got my HS CAI from Luke at Digitalracer. I've read thru a few threads to make sure I can get all the tips I could for my install. Now my problem was as I looked at a few pics of final intalls, I couldn't really tell how the piping sat especially the from the MAF to the fender.
Well today I decided that I would give it a go and hoped for the best. Before I made the hole larger, I tried to line everything up. It seemed the the piping from the intake to the MAF seemed to screw everything up, of course I turned it around to see if it was just me, well it still sat funny. I pressed on and cut the hole hoping to see if I just needed the room to make it fit properly.
I printed a couple copies of final intallment pics (One of them b-b00gie since he has a P11, I figured it would be the same, except that I didnt have a BPV) to no avail, the install did not work.

So anyone who has a HS CAI installed or someone who had bought one from Luke's recent group buy, did you have a problem with getting the wrong piping? The part number I recieved was NS4003-75. Could it be that I didn't make the hole cut properly? There were no illustrations w/ my installment paperwork that came w/ the CAI. Here's a pic of the piping that I recieved.

http://photos.yahoo.com/bc/littlerudegirl/vwp?.dir=/Yahoo!+Photo+Album&.src=ph&.dnm=cai+parts.gif&.view=t&.done=http%3a//photos.yahoo.com/bc/littlerudegirl/lst%3f%26.dir=/Yahoo!%2bPhoto%2bAlbum%26.src=ph%26.view=t

Any info would be great! ;)
 

·
Registered
Joined
·
3,357 Posts
We def. got a def kit mine ws 4001 andI had more pipe in my kits than that. I " helped " install it but mostly watched whle they cursed, 2 hours job plus I had to buy this plug that was missing. But man it sounds sooo good at night and my AT loves it def. I little more pick up

Box:


Pic 1:


Pic 2:


I will take more for you later ...
 

·
Registered
Joined
·
74 Posts
I have a 2000 and received NS4004-75.
On the packaging it says it's for a 2.0 Nissan Sentra SE so I asked Luke and he said it was fine.

On the pipe, it has two little valves sticking out from it, and it looks like you have three, so I don't know what's going on there.
 

·
Registered
Joined
·
5 Posts
I also have a 2000 and bought the HS CAI (Part #NS4004). The shop I took it to said it would be very difficult to install, so they custom-made a Hi-Flow intake for me to use. Can anyone tell me the steps you used to install your CAI? Can anyone recomment me to any SR20DE specialists in New York City or Northern New Jersey that would be able to do this install?
 

·
Registered
Joined
·
963 Posts
If im not mistaken, there is a place that does swaps in new york city, called Performance Factory. Im guessing they would know how to help out.
 

·
Registered
Joined
·
3,357 Posts
frogg said:
I have a 2000 and received NS4004-75.
On the packaging it says it's for a 2.0 Nissan Sentra SE so I asked Luke and he said it was fine.

On the pipe, it has two little valves sticking out from it, and it looks like you have three, so I don't know what's going on there.

I used a rubber plug to cap the third one off. Take more pics manana .....
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #7 ·
here are some links

FINSTER 187 said:
I also have a 2000 and bought the HS CAI (Part #NS4004). The shop I took it to said it would be very difficult to install, so they custom-made a Hi-Flow intake for me to use. Can anyone tell me the steps you used to install your CAI? Can anyone recomment me to any SR20DE specialists in New York City or Northern New Jersey that would be able to do this install?

These are the links that I checked out for installment:


http://www.geocities.com/MotorCity/Track/9085/

http://www.automotiveforums.com/vbu...+intake+install

http://www.sr20de.net/engine/index.html
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #9 ·
jayntguru said:
Even if you were sent the wrong part, you can still install it.

This is the "wrong" one that I purchased from someone a while back. Fits just fine.

You have a P10, is there a difference of CAI between yours and for a P11?
 

·
Registered
Joined
·
3,357 Posts
MORE PICS HOPE THEY HELP





 

·
Registered
Joined
·
142 Posts
poppy do you have astigmatism or something? :lol: no offense, man, but seriously your pics are always out of focus. Reminds me of my dad, he always forgets to put it on auto focus and walks into light poles while putting sunscreen on his nose. Anyway I don't mean to be a dick but check out your camera cause I think somethings messed up. :D
 

·
Registered
Joined
·
3,357 Posts
Stevo said:
poppy do you have astigmatism or something? :lol: no offense, man, but seriously your pics are always out of focus. Reminds me of my dad, he always forgets to put it on auto focus and walks into light poles while putting sunscreen on his nose. Anyway I don't mean to be a dick but check out your camera cause I think somethings messed up. :D
It because I take the picture too fast and my hands are moving. I always take picture when I am on my way into work or in a hurry.. you can see the second picture was clear but the others were fuzzy. I need to use the flash
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #14 ·
CAI Installed!!

:p Woo Hoo!!! :p Got that sucker in there today, all by myself. I just had to widen that hole a little bigger. Now all I gots to do is cut the battery plate to fit around the intake pipe and I'm good to go.
I do have to say the G ride sounds a lot more open. Also if you're running that A/C, you won't bog down as bad.

I feel it in my bones fellas... I'm gonna need more power, that DET is gonna get into my ride sooner than I thought!! :lol:
 

·
Registered
Joined
·
3,357 Posts
Re: CAI Installed!!

littlerudegirl said:
:p Woo Hoo!!! :p Got that sucker in there today, all by myself. I just had to widen that hole a little bigger. Now all I gots to do is cut the battery plate to fit around the intake pipe and I'm good to go.
I do have to say the G ride sounds a lot more open. Also if you're running that A/C, you won't bog down as bad.

I feel it in my bones fellas... I'm gonna need more power, that DET is gonna get into my ride sooner than I thought!! :lol:
Good to hear that.

I think I worte the same thing about the CAI .. it makes you hungrier for more power ...!!

AC def. better
 

·
Registered
Joined
·
5 Posts
nsng20 said:
If im not mistaken, there is a place that does swaps in new york city, called Performance Factory. Im guessing they would know how to help out.

I just got mine in this past Thursday, too. Thanks to nsng20 for the reference to Performance Factory. That's my spot now for the rest of my mods. I'm lovin the CAI.
 

·
Registered
Joined
·
98 Posts
nfo good will be installing mines this weekend
 
1 - 17 of 17 Posts
Top