Infiniti G20 Nissan Primera Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Since I bought my car the key FOB only worked whenever it wanted. The times it worked ( rarely it would work) I would press a button for over 5 seconds (if lucky) for the car to respond.
Eventually it was useless to carry the FOB with me since it never worked.
The first thing I tried was changing the battery but nothing happen. I did a lot of research here but came up with nothing new beside "buy a new one on ebay". I checked on ebay but didnt want to spend the money not knowing for sure if was a bad key FOB or something else in the car.
So yesterday I opened up the FOB and cleaned the rubber part of it. It was pretty dirty, looked like some kind of liquid got inside because it was sticky and stained. Anyway, after i cleaned a little bit and put it back together the lock button started working 2 times out of 6 tries.
Today I went to Home Depot and bought CRC 2-26 Multi-Purpose Lubricant



Again, I took the key FOB apart and soaked the "electric card (?)" with this lube, let it set for a few minutes and cleaned the excess with a Q tip and paper towel.
Key FOB works 100% now :)

Hope this helps someone out there who think they have a dead or unresponsive key FOB
 

·
Registered
Joined
·
1,444 Posts
ill try it same problem but the noise when locking the car does not even work!
You might have accidentally turned it off. Press lock and unlock at the same time for 2 seconds to turn it back on. (Instructions on back of remote.)
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top