Infiniti G20 Nissan Primera Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am trying to get my nieces' first car on the road for her. The ign fuse kept blowing so a 30 amp was put in(I know,,,I know) and they ended up frying the IAC connection and all. Anyway new valve is in and I hope I wired the connection right. The car will not idle right. It revs to almost 3k. I have heard the ECU has to "learn" the new part. Is there anything that needs to be done before trying to drive it. Thanks in advance for any input.
 

·
Registered
Joined
·
8,170 Posts
if this is 00+ g20 I would also check the ECU for damage. Also there is an idle air relearn procedure that must be done. It's damn near impossible to do and most end up at the dealership so they can just plug it in and do it from their scan tool.
 

·
Registered
Joined
·
3,520 Posts
It's his first post give em a break.

If it's a 02 do the relearn procedure. It's on the forum somewhere. You'll have to try it about 20 times before u get it right. I know I did when I unplugged My iacv. I have a spare to incase ur ends up being bad just FYI.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Damn tough crowd here. Yes,, I am a newbie. DM Sentra what do you mean by dead niece. I said it's her car that I am trying to revive. Never said she was gonna drive it before all was ready and safe. Thanks for the good info to everyone. I am still trying.
 

·
Registered
Joined
·
50 Posts
My car has had a bad IACV since as long as I can remember. I installed one I bought from Ebay (maybe my 1st mistake) and it worked for less than a day. I sent it back and the guy sent me another one. I suspect he sent me a pre 2000 IACV but I can't be sure. I noticed that the valve he sent me had some sort of aluminum shied/gasket which was shorting stuff out. I removed it and was able to get the car running by holding the gas as I turned it on. Its a pain in the ass but after holding the gas to turn it on it behaves for the most part.

I'm not sure if I should order another IACV from somewhere else or look into getting a new ECM. I hear that could be the problem as well. I tried the relearn thing but that didn't help.
 
1 - 7 of 7 Posts
Top