Infiniti G20 Nissan Primera Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
605 Posts
Discussion Starter #1
While scrolling through the NJ meet pix I came across this:

Anyone know what kind of ignition setup this is?
 

·
Registered
Joined
·
844 Posts
thats my friend joels car. im pretty sure its an msd set up. not sure the specifics but ill go ask him for you.
 

·
p10 guru
Joined
·
2,908 Posts
i think thats a standalone system. cant remember the name tho. could be wrong however
 

·
Used to own a P10
Joined
·
5,396 Posts
Does he really have a VE+T?
 

·
Registered
Joined
·
605 Posts
Discussion Starter #6
^^^Thats exactly what I was thinking. And ya im pretty sure it is a standalone system but I wanted to find out what brand.
 

·
Registered
Joined
·
844 Posts
yes its a ve-t. he built up the bottom end with all his gti-r goodies from his last engine. he does use a tec 3 standalone but hes got a weird ignitino set up. ill let you know whenhe answers back.

btw thats his spare turbo he has a bigger one.
 

·
Registered
Joined
·
844 Posts
yea i just talked to him its definately a tec 3. btw in case you couldnt tell he has a b14 not a g20.
 

·
Registered
Joined
·
605 Posts
Discussion Starter #10
Thnx. Ya I kinda assumed that cuz of the suspension mounts and the grill. Did he have a problem with valve lift or sumthin like that? I wuz lookin into ve+t's before and remember a valve problem being mentioned as common?
 

·
Registered
Joined
·
844 Posts
Mxer683 said:
Thnx. Ya I kinda assumed that cuz of the suspension mounts and the grill. Did he have a problem with valve lift or sumthin like that? I wuz lookin into ve+t's before and remember a valve problem being mentioned as common?
im not sure. he is over on sr20forum.com and his handle is slow 96r if you wanna ask him.
 
1 - 12 of 12 Posts
Top