Infiniti G20 Nissan Primera Forum banner
1 - 12 of 12 Posts

·
Premium Member
Joined
·
6,140 Posts
Discussion Starter · #1 ·

·
Registered
Joined
·
8,172 Posts
Great find. Is the obdI codes the same as the ECU flash codes? If so is that all of them as I had a post on here that showed alot more I think.
 

·
Registered
Joined
·
8,172 Posts
p1400 is EGR control solenoid valve and p1105 is Map/baro switch solenoid valve. I have a link right in this thread with the answers.

Did you perform any work on the car? These codes would lead me to believe you have two vac lines not connected. Map sensor is on the firewall and is says "boost sensor" on it.
 

·
Registered
Joined
·
8,172 Posts
you can try to replace the boost sensor. That didn't work for me when I had that code. But I was boosted and that sensor doesn't like to see positive pressure. You aren't boosted by any chance are you?
 

·
Registered
Joined
·
27 Posts
Lol no, just bone stock afaik, minus my removed resonator & muffler (Which I'm putting a performance muffler to quiet down the straight pipe).
The only work I've done to the car is: Basic tune-up - Oil change, spark plug replace. Haven't replaced wires yet, they seem good. Before doing the tune-up I got "Misfire in cyl. 4", now that error is gone and I'm receiving these 2 codes.

The car sounds so good full straight pipe, minus the raspiness near gear switch, but it's such a drone and gives my passengers in the back seat a headache.. Plus I think it knocked the straight pipe off the flex pipe because every time the rear of my car goes over a bump, as it hits the end of the bump I hear what sounds like a tin can scraping the street or bottom of my car :mad:
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top