Infiniti G20 Nissan Primera Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Yesterday, the pressure on my clutch pedal went out and I'm wondering if my clutch is going out. The clutch still engages, but for how long I don't know? I asked someone who knows more about cars than me and they told me it could be it needs fluid. What do you guys think the problem is?

Should I continue to drive it? Or should I wait until Monday to take it to my mechanic?
 

·
Premium Member
Joined
·
1,103 Posts
first of all our cars dont use fluid pressure to engage/disengage clutch, we have a cable, which might be the cause of your problem...

if the cable is worn out (streached) or the adjustment screw stripped out you will notice the problems you are in right now (cheap fix, check out ebay, ive seen cables going for $30).

if your problem is the clutch itself, expect to pay around at least $150 for the clutch (without labor) (again check out ebay, nice clutches starting at $120 w/ out shipping). good luck
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
Thanks for the info. So, do you think the car is safe to drive? At least until Monday when I take it to my mechanic.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #7
Weird. I drove my car today for work, I use it as a delivery car at the moment, and after a few hours of driving it the pressure came back on the pedal. I don't get it. I'm still taking it to my mechanic tomorow to see what's going on with my baby. Thanks for the info y'all.
 
1 - 7 of 7 Posts
Top