Infiniti G20 Nissan Primera Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I've got thick black fluid that i suspect to be gear lube or possibly oil from the rear main seal coming out of where the engine and trans bolt up. Also, not surprisingly, the clutch is starting to slip. Other than the rear main seal, how the hell is this fluid getting inside the bellhousing to leak anyway? 1995 P10 with UK Redtop and JDM LSD trans.
 

·
Registered
Joined
·
1,361 Posts
Pat is right. It is the rear main seal on the engine, and it is engine oil you are seeing. Auto trans fluid would be red oil, manual trans oil would be clean oil.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
It was the input shaft bearing, it had somehow destroyed itself. We rebuilt the trans and are waiting for a new clutch to arrive. Rear main seal was still perfect.
 

·
Registered
Joined
·
12 Posts
i know this is an old thread but how could you tell that your input shaft bearing was bad? i am leaking gear lube in my manual p10 and have replace the output shaft seal twice already
thanks
Dan
 

·
p10 guru
Joined
·
2,908 Posts
just pulled the trans on a 95 p10t. i wasn't sure if the TOB or input shaft was making noise. turned out to be the input shaft bearing and that caused the input shaft seal to leak also. also, when the gear oil leaks into the bellhousing, it spills onto the ground PITCH BLACK. this is because it travels through all the clutch dust in the bellhousing. you can tell by the smell though
 
1 - 7 of 7 Posts
Top