Infiniti G20 Nissan Primera Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I just bought a 2000 G20 with 170K miles for $3050. The guy I bought it from said that the heat shield is lose and makes a vibrating noise everytime he starts the car. So I figured I will just replace the heat shield and be done with the problem.

But it turns out that that is not the case. I took the car to my mechanic and the first thing he said was this is a problem car. However he was still willing to help.

So I told him how it is a heat shield problem and he simply ripped the shield out. However, that has not solved the problem so I brought my car back without the heat shield and no reduction in the start up noise.

So then I decided to investigate the source of the noise and found out that it was coming from the passenger side of the engine. Then I noticed that there was some kind of bolt missing on some tin-like thing and so I turned on the car and pressed on that tin-like thing. It seemed like that reduced the noise a little, but still it doesnt seem to be the problem.

Also everytime I put the car in reverse I hear a similar noise that is not as loud as the one in idle but still noticeable.

I want to know what the problem is. Anyone have this problem before? I feel embarassed to start my car in the morning because of all the noise.


PS: The car runs normal when I put it in drive. Even when the engine is cold, the car makes no noise in drive.
 

·
Registered
Joined
·
72 Posts
I have the exact same problem! i haven't found out the answer because I haven't tried anything (lacking money)

It might be the motor mount but i'm not sure. hopefully someone can give you a definite answer

P.S. this would probably be better in the engine part of the forum
 

·
Registered
Joined
·
920 Posts
I have the exact same problem! i haven't found out the answer because I haven't tried anything (lacking money)

It might be the motor mount but i'm not sure. hopefully someone can give you a definite answer

P.S. this would probably be better in the engine part of the forum
that seems to be my guess with the amount of information given...gl
 

·
Registered
Joined
·
100 Posts
I also have had the same problem. My mechanic put 2 clamps on the heat shield and it took care of the rattle for about 3 weeks. But the clamps get loose and the rattle starts again. He suggested that I rip them out but I'm not doing that. Can the shield be replaced?
 

·
Registered
Joined
·
72 Posts
What/Where are the heat shields?
What exactly do they do for the car anyways? I shall do a forum search :)
 
1 - 8 of 8 Posts
Top