Infiniti G20 Nissan Primera Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Does any one know what could have caused this? They all just stopped going on all of a sudden, and it makes it hard to drive at night, not to mention that I got pulled over last night because a police officer didn't think I had my lights on. The turn signal and reverse lights work fine, it is just the normal rear lights, although I'm not sure if the brake light still work. Could it just be something simple like a blown fuse? I have a 1993 by the way.
 

·
Registered
Joined
·
117 Posts
tail light fuse

its the tail light fuse. the braking lights should still be working, but not while not braking. otherwise that cop would have been super pissed :)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Alright, I replaced the Tail Light fuse and my clock started to work again, but then when I turned on my lights, the dash lights and tail lights worked for a second before the fuse blew. I'm using the same size fuse as was in there before, what is causing it to blow? Do I need to unhook something before I change it?
 

·
Premium Member
Joined
·
11,383 Posts
Sounds like you have a short in your system. OR you have too much amperage pulling thru the fuse, which leads to another short. Do you have any aftermarket things hooked up to this power line that draws more current? Another thing to check is your ground on the battery terminal, if its all crusty and nasty, clean it with some baking soda and water.

Shorts are a PITA to isolate....check the bulbs, and make sure all the filiments are good, thats the first place to start. If you have aftermarket bulbs (PIAA, etc) check the wiring harness and make sure they are not melted or damaged....from there you'll have to follow the hot leads and check for damaged / bare wires...good luck.
 

·
Registered
Joined
·
233 Posts
it could also be a bad ground back there.
 
1 - 6 of 6 Posts
Top