Infiniti G20 Nissan Primera Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4,452 Posts
Discussion Starter #1
Most of the time in the morning when its freshly starting my 1992 G20 hesitates to start, you hear it cranking and igniting but it wont hold its idle unless I add gas for a few seconds, other than that it will try to die out. I just change the oil to 10-40 and its still giving the same problem, but just about daily when you least expect. Even when I drive all day long and let it sit for about an hour, here we go again.... The problem just started, as soon as I change to 5-30 oil two months ago

I got my last tune up exactly two years ago, new wires and plugs(bosch), and everything else in-between. Is it time for a new tune up already? Please Help.
 

·
Registered
Joined
·
89 Posts
I'm no expert by any means, and I don't want to state the obvious, but, it sure sounds like an ignition problem to me.

You don't give the mileage, nor how and on what type of roads you drive, nor do you describe how the car runs after you have it started and warmed-up. If you want more specific answers, you'll have to supply ALL the specific info!
 

·
Premium Member
Joined
·
11,383 Posts
Re: My G starts but... urghh "Help Plz"

ERIKbronx said:
I got my last tune up exactly two years ago, new wires and plugs(bosch), and everything else in-between. Is it time for a new tune up already? Please Help.
Gaz is right, how many miles has it been since the last tune up? That would be a great place to start. You will be amazed at what a new set of plugs, wires, and rotor will do for you. Other things could be the injectors, maybe even the O2 sensor...just a guess tho...good luck and if worse comes to worse get it checked out...
 
1 - 3 of 3 Posts
Top