Infiniti G20 Nissan Primera Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
635 Posts
Discussion Starter #1
Hey everyone I just started to get this weird problem with my ride and I was hoping you guys can help me figure it out. I got a 93.5 automatic with 147000miles. Well, recently my car is having a problem getting out of park. The shift button only compresses halfway and won't let me shift into reverse, D, D1,etc. What I do is rapidly tap on the shift button and the brake while wiggling my steering wheel and it takes about a minute or so till the button fully compresses and lets me pull it down into R, D etc. Any clues?


I don't believe its the shift lock because I can hear the click noise when I push on the brake while in park. I have a torn up upper engine mount but I just bought a new one from scottsdale infiniti but haven't put it in yet. If anyone knows whats up please reply It gets kind of scary when it takes more than a minute to get the button to work makes me feel like calling a cab.
 

·
Registered
Joined
·
59 Posts
yo bro,as I am in the same situation and looking for help, but I some how figured out a temporary solution. You need to remove the cover for the automatic shift and remove 4 screws that is holding the housing. Try to lift the housing and you will see a
WHITE cup shaped piece. Press the shift buttom on the shifter and you will see the shifter being blocked by the white cup.
Twist the cup forward toward the engine and press the shift buttom at the same time. Give it a try.

or call me at 914-316-6199
 

·
Registered
Joined
·
635 Posts
Discussion Starter #3
thanks for responding to such an oldschool thread...thats cool. well my auto tranny mount was shot. I only noticed this when I was having some jerky tranny problems which was basically a failing drop resistor which was making shifts rough and tearing up that tranny mount. I replaced both and everything is just lovely now. It shifts super smooth in the gearbox and on the road. thanks for looking out.
 

·
Registered
Joined
·
59 Posts
No problem, Bro. Maybe you can help me out. You know how when you step on the brake paddle and you will hear a clicking sound, then you shift, the clicking sound is no longer there and I can't get the shifter out of park unless I do what I said in the above mentioned email. Do you know how to solve that problem ? please help.

PS. how much did you pay to get your shifter replaced?
did you go to a dealer ?
 

·
www.iheartboost.com
Joined
·
3,747 Posts
i duno if you*re interested or if you*re still even having the problem (hopefully you*re not anymore) but i have a 93 auto tranny for sale... it ran fine when i took it outta my car, has 106k miles on it. if you*re interested, make an offer.
 
1 - 5 of 5 Posts
Top