Infiniti G20 Nissan Primera Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
2,522 Posts
Discussion Starter · #1 ·
heres the deal...this is a follow up to this thread: Still Clunking

im not even going to begin to get into how much shit i have
gone through to solve this problem...but a lot of money, 3
mechanics and 2 dealerships later and this is still happening.

whenever i go over a bump, or a rough road, i get a clunking coming
from the drivers side foot-space/axle area. it feels as though that
whole section of the car is loose and broken.

Heres what i have recently discovered:
When i have the car running and sitting at a stand still, by moving
the steering wheel back and forth i feel and hear loose clunky movement
coming from the drivers side foot-space/axle. it feels as though
when i turn the wheel there is some "dead" movement before the
tires begin to actually turn. when its cold out this sound and feeling
is extremely obvious and dangerous sounding.

I havnt had a chance to put the car up since i discovered this problem,
and wont have a chance until the summer. please help me out if you can!

What has been replaced:
-Shocks
-Upper Control Arm
-Sway bar links/bushings
-CV Joint
-Inner and Outer tie-rods
-Full inspection by a Nissan and Infiniti dealership,
along with a few local mechanics, me, and my dad.
 

·
Registered
Joined
·
129 Posts
what it sound like to me is you CV Joint b/c thats what my did both times when they went but you said you already replaced them.
 

·
Registered
Joined
·
462 Posts
Are you saying mechanics looked at the car and could not figure this noise out? Well, I am assuming they checked all the suspension parts, so I would try to check the transmission mount to see if it is badly worn out.
 

·
Registered
Joined
·
2,522 Posts
Discussion Starter · #4 ·
pmaadani said:
Are you saying mechanics looked at the car and could not figure this noise out? Well, I am assuming they checked all the suspension parts, so I would try to check the transmission mount to see if it is badly worn out.
yes mechanics have looked, tried, failed, and cost me a ton of money :tired:
i prob should have mentioned that iv changed both cross member mounts
and all three engine mounts about 4 or 5 months ago in an attempt to
remedy the problem
 

·
Registered
Joined
·
2,522 Posts
Discussion Starter · #6 ·
pmaadani said:
Ok, are u losing any power steering fluid? or Do you have excessive play when you move steering wheel?
power steering fluid level is fine.
like i mentioned in the first post, that loose, broken, clunky
grinding sound that happens when i turn the wheel at a stand
still feels as tho there is excessive play under my feet.

i thought for sure the new CV joint would solve the
problem. but no such luck with this damn problem
 

·
Registered
Joined
·
462 Posts
Excessive play when you turn steering wheel might be the sign of steering rack failure since there is nothing wrong with suspension parts and you have change anything else that could make this noise! This is just a guess. don't spend money yet!
 

·
Registered
Joined
·
2,522 Posts
Discussion Starter · #8 ·
i was wondering about that. but it doesnt feel like its in the steering column.
it feels like its coming from somewhere down by the axle or lower suspension
parts. could the steering column cause a clunk? b/c im almost certain this problem
is the source of the clunk, b/c i feel a slight clunk when i do this steering wheel
thing. same sound, same feeling, same spot.
 

·
Registered
Joined
·
107 Posts
two days ago my wife's car does that tÖo. I crawl under the car-fucking sway bar bushing on driver side is gone!!!just the bar and the bracket. It does not clunk or loud, only over pot holes or uneven shitty roads.
The sway bar and stabilizer bracket also lÖose. So check the bushings and make sure its tight.
 

·
Registered
Joined
·
2,522 Posts
Discussion Starter · #11 ·
bhowle said:
I'm gonna say steering rack as well.
do you have any experience with this?

docG20 said:
two days ago my wife's car does that tÖo. I crawl under the car-fucking sway bar bushing on driver side is gone!!!just the bar and the bracket. It does not clunk or loud, only over pot holes or uneven shitty roads.
The sway bar and stabilizer bracket also lÖose. So check the bushings and make sure its tight.
as stated in the first post, i replaced the bushings and end-links already.
iv been under the car 100x to check and make sure everything is bolted
down and tight, and it has been (i have an impact gun, torque wrench,
and breaker bar)
 

·
Registered
Joined
·
2,881 Posts
I know you've had this for a while so I'm just trying to think, sorry if these are repeats from a prior thread

1) When you replaced the front struts did you change all of the strut mounts, and everything in that assembly, were the struts ever blown?
2) Have considered removing the sway bar entirely and driving for a few days (would probably not handle as well but that's ok
3) How are your motor mounts? (I think you already replaced this)
4) Can you hear the sound from outside of the car?
5) I know you wiggled everything, caliper is tight? What about stuff in the engine bay in front of the pass side wheel well.
6) Have you considered swapping/rotating the tires (maybe something is warped??) and seeing if the clunk dissapears or moves?
7) I don't know but what other bushings are there? Just a question because you mentioned temperature makes a difference!

I'll try and think of more stuff!
 

·
Registered
Joined
·
34 Posts
Merlin gives good advice, my car does the same thing, i'm going to try the strut first because its making noise going over bumps also, on the top of the struts there is a mount and a bearing (not a roller bearing, its like a plastic gromet-type thing) that i've seen break on i30s, when you replaced the strut did you replace this and the upper strut mount also? i've also seen those aluminum links that mount to the body and the control arm make those kinds of noises due to the busing wearing out on them, just a couple things to look at.
 

·
Registered
Joined
·
472 Posts
well i am going to go with previous post and say i think its the steering rack. i changed one before (but with no engine in car), but the only way you can tell is by putting the car on a lift and turning the wheel at the same time while somebody is looking at the steering rack to see if anything is broken or loose. and you should go back to the dealerships and get your money back if they can;t fix the problem.

Questions to be asked?

When did the problem occur?
What happened before the problem started?
 

·
Registered
Joined
·
2,522 Posts
Discussion Starter · #16 ·
Merlin thanks for the advice bro. i never thought about taking off
the sway bar and driving around. i didnt even know that possible actually.
everything you mentioned was replaced and checked, and i have gone
through one set of tires (propper rotations) and still the problem persists.

mediumred91lx: yes the upper mounts have been replaced.
twice on the side that has this problem just for insurance,
but it didnt make a difference at all

Primerat: i have gotten refunds from the dealerships when they tried to fix the
problem specificaly. but when no one could figure it out my old man and me
started replacing parts that could potentially be the problem one at time.
The problem started right before i installed my eibach and konis when
my stock suspension was shot. i thought getting new springs and struts
would remedy the clunk but it didnt. a

Sooo...the steering column eh? that would make sense. could this be
even though i never feel any noticeable differences in my steering
when going over bumps when the clunk occurs? im goin to see if i
can get the car on a lift and inspect it sometime soon. i cant imagine
this being very safe
 

·
Prince of Joy
Joined
·
4,614 Posts
njprimera said:
Sooo...the steering column eh? that would make sense. could this be
even though i never feel any noticeable differences in my steering
when going over bumps when the clunk occurs? im goin to see if i
can get the car on a lift and inspect it sometime soon. i cant imagine
this being very safe
Just get some Rhino ramps. Should take two seconds to make sure the rack is securely mounted to the firewall.

It could definitely be your swaybar -- I just assumed that since you replaced all the bushings it was installed correctly. Might want to double check that while youre under the car. Just grab the swaybar and yank on it -- make sure it is solid.



- Greg -
 

·
Registered
Joined
·
1,247 Posts
I have the same problem coming from my left foot.....its getting worse, it clunks and when i step on the brakes it rattles and clunks alittle more. I thought i was the only one. Infiniti by me said there was nothing wrong. Sometimes when i take off it knocks too....is that what happens to u. Also mine gets louder and more frequent with my aftermarkets wheels
 

·
Registered
Joined
·
3,940 Posts
i would say steering rack.
 
1 - 20 of 38 Posts
Top