Infiniti G20 Nissan Primera Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi Folks,

My 1999 P11 (auto tranny) is at the dealer due to a very rough idle and I need some quick advice. What happened whas that one day last week while running the AC a lot of water suddenly began to run out from under the dash (yes it was only water). I think it was condensation from the AC (but it could have been some type of a leak from the cowl I guess). Anyway, the next day the car is running very rough and stumbline. According to the dealer, water leaked onto the ECU and "shorted" it out. The consult gave up codes for:

1) Bad knock sensor
2) Multi-cylinder misfire

The stealership said I need a new ECU for $995 and a new Knock Sensor for $400 but he didn't reset the ECU and see if the (now dry) ECU operated properly. I got prices for both from infinitipartsusa.com of about $600 (ECU) and $125 (Knock sensor) and I can do them myself (knock sensor is a bitch but a 12mm wrench and some cursing will get it). My questions are as follows:

Has anyone had this "leak" from the AC before (and what was the cause/fix)?

Should I try resetting the ECU before I buy a new one (with the hidden screw on the ECU inside the dash) and see if it works better now that its dry?

How can I tell if the ECU really is fried?

Thanks for all the great advice,
Paul
 

·
Registered
Joined
·
562 Posts
wow...you are having some major problems I see....I also have a 99 G20t but I have no clue why my engine is alittle rough on idle...and I also have a engine light but reads "Overrun Clutch Solenoid" but thats weird because thats a automatic transmission code and I'm manual. This isn't the original motor but another 99 G20 motor since I blew the piston rings on my original motor. I don't even know how I blew it either....I had JWT cams and intake headers and exhaust....but I took all the AFC and multi-checker off the ECU....but I'm guessing some wires might have got screwed when either installin or uninstalling AFC and multichecker....and could have made my car blow rings. The ECU could also be screwed... Man maybe 99s just have problems....
 

·
Registered
Joined
·
26 Posts
the a/c issue is simple. condensors always drip, theres a drain hose that runs to the outside of the car that is probably plugged.
 

·
Registered
Joined
·
778 Posts
Don't see how the AC could drip onto the ecu. The main harness is to the left, the airco heater core and hoses to the right.

If the ECU was shorted you'd have more problems.

Knock sensor is about the only sensor that is funked if consult says so.

Multiple misfires..... Timing not correct? (retarded too far because of bad knock sensor?)
 
1 - 5 of 5 Posts
Top