Infiniti G20 Nissan Primera Forum banner

1 - 4 of 4 Posts

·
La-illaha Il-lallah
Joined
·
2,034 Posts
Discussion Starter #1
Ok so t bags installed what seemed to be a rebuilt starter that I bought off of a member here several months ago. The starter had paperwork and was rebuilt a few years ago actually.

From the get go the starter would make a whirling sound when starting. Well today I went to start and the starter makes this loud whirling sound and does not start the car. The sound continues for a few minutes then goes away. Is there an issue with the mounting of the starter or the starter itself?
 

·
La-illaha Il-lallah
Joined
·
2,034 Posts
Discussion Starter #2
Wow... with all the starter troubles no one has had a starter behave similarly. It feels like its not seated right but I wanted to know.
 

·
Registered
Joined
·
144 Posts
Did you get the starter checked at your local auto store. When my van's starter was going out, I had it checked to make sure it was bad.

I did replace my starter on the G last spring with a rebuilt one from the auto store. After putting it in, it worked fine. If yours was making an unusual noise, I'd guess it was the starter that was bad. If it was improperly installed, it probably would not work at all.

Just my guess. I'd crawl under the car and see if you see if it was seated correctly (I can't remember if it was easy to see...I think you just have to squirm around a bit and then you could see it). But I think the starter was bad.
 

·
La-illaha Il-lallah
Joined
·
2,034 Posts
Discussion Starter #4
Thanks for the reply. I think I will take the starter to be tested. The car died with the new starter two days after it was installed. Luckily it died in front of a NAPA. I had to have them get a new starter and install it. $220 later the car starts. But I still hear the starter sort of spin free even after the engine has turned over. I don't know if this is normal.
 
1 - 4 of 4 Posts
Top