Infiniti G20 Nissan Primera Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,472 Posts
Discussion Starter #1
I got a nice Alpine deck off my friend a couple weels ago but I had an install problem. My stock trim overlaps the Alpines side trim and sticks up a little right now w/o the trim piece even on. I was wondering how every over came this problem or am I alone? Do I need to sand down the back side of my trim piece?
 

·
Registered
Joined
·
664 Posts
I'm guessing you are trying to use the "E" size trimring - well you can't. The G20 isn't an E style fit. If your alpine came with a slim fit (meant for sizes I and J - our G20s) then you have to use that trim ring. Other than that - yes slight modification will be required, or simply remove all trim rings. That's what I had to do - it doesn't look pretty but Pioneer didn't give me a slim trim ring.
 

·
Registered
Joined
·
1,472 Posts
Discussion Starter #3
I never put the trim piece on and it still doesnt fit right. Im really picky and if its not right, im not done with it. So I guess im going to have to do some custom work and get the J trim.
 

·
Registered
Joined
·
664 Posts
are you sure u screwed the bracket into the "T/N" (toyota/nissan) screw holes?
 

·
Registered
Joined
·
562 Posts
I know what you are talking about....my Alpine on my P11 looks like it sticks out without the trim....try this....does the deck look flush and nice when you take the face plate off? Then its the same problem I had...but I used the Alpine trim they gave me...all I did was shave off alittle both sides until if fit in there nicely...be careful and not to trim too much or else you will see it...
 
1 - 6 of 6 Posts
Top