Infiniti G20 Nissan Primera Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
Hello, first the introduction. been doign a small amount of reading and lerking. The name's Tim and i'm thinking about picking up a 93 G20 from the towing company where i work as a DD/beater. Ive owned 3 300ZXs since i was 14 and i'm pretty handy with a wrench. From what ive read ya'll seem like a nice knowledgable bunch here. (i appologize in advance for the long post i promise this isnt ganna be a habitual thing) :lick:

Now to the technical. I've been doing some reading through the faq and understand that like any other car (especially the Z) these things dont like to be neglected maint. wise. SO me working for a towing company and this car being towed by the sheriff's office, i have no previous maint records. I only plan on driving this car for about 3-4 months before i leave for the USAF but i dont want it to blow up on me after a couple of weeks. I plan on making regular 270 mile trips if that helps. Problems ive managed to find on the car so far:
Oil pan appears to be leaking, thank god its not a RWD and has a cross member through it so its no problem to pull it, but is it a cork gasket or can i use RTV silicon?
Power steering high pressure hose appears to be leaking, again looks like cake to fix it but is there anything else that commonly fails? also, is this like the Z's power steering system that calls for ATF?
Timing chain, what incraments does this need to be replaced, is the SR20 a contact motor? and is it a huge huge risk driving on the ticking time bomb of not having it replaced, or is it not as risky as a belt.
Speedo needle is broken off somehow, tach works fine doesnt do the bounce thing like the faq said to watch for. I found a 91 G20 in the local u-pull-it yard but didnt realize that the speedo is cable driven and not electrical like my Z's, is there some kind of secret to removing the cable lead without breaking the clip becuase thats what i did to the junkyard car (oops). I looked below by removing the under steering wheel trim and all around and i cannot see or get my hands behind the cluster to pull it out the proper way. Also, will the milage counter work even if the speedo does not or is it all part of the same mechanism?

Again i appologize for the lenghty post but thanks in advance guys.
 

·
P10 FTMFW!!!
Joined
·
2,489 Posts
1) Use RTV silicon, but check to make sure the oil pan isnt damaged. if it is, get a new one and use the rtv on it.
2) i believe the FSM says to use ATF for the fluid but im not sure offhand.
3) no it does not need to be replaced like a timing belt.
4) i've never removed the gauge cluster yet which i have to do at some point anyhow. you do have to remove the lower panel below the steering wheel but i dont know where the other screws are.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #3
awesome thanks for the speedy reply. Ive removed all the trim i just cant figure out how the hell to get my hand in there to properly remove the clip.
 

·
Registered
Joined
·
3,940 Posts
welcome aboard. hope u get those answers you were looking for. :)
 

·
La-illaha Il-lallah
Joined
·
2,034 Posts
Luminar said:
awesome thanks for the speedy reply. Ive removed all the trim i just cant figure out how the hell to get my hand in there to properly remove the clip.
I read a long time ago that you have to tilt it all the way to one side so that one side is in against the firewall and the other is out towards you. Then reach in from the side out towards you and remove that clip. Then push it in from the other side and remove the other clip. Finally you can remove the middle one.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #6
hmm. i'll give that a try when i head into work today.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #8
yeah as it turns out, its not a cable speedo. i checked into it at work today and its a 93.5. so that would mean that its an electrical connection. guess that maeks life easier. Anyone got one for sale =P
 
1 - 8 of 8 Posts
Top