Infiniti G20 Nissan Primera Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi everyone,

Well I'm loving this forum! Everyone is so knowledgeable with great friendly advice... so I thought I'd try my luck with the sound system I've (started) setting up in my '91 P10.

It started off with an aftermarket head deck (Sony), stock speakers in the front, and Blaunpunkt in the rear - they were fitted directly in the original holes, but were bust.

I decided to replace the rear with 6x9s - but am pretty sure I went about it in the wrong way... I basically took out the (round) blaupunkt speakers, then cut the parcel tray, and took to the metal-underneath bit (terrible terminology I know) with a jig saw, and extended the existing holes to take my JVC 6x9s.

The cutting wasn't great so the JVC's weren't flush, and not screwed in or anything... anyway I put it all back together and it works, but

a) very little bass (im sure the speakers can do better)
b) looks terrible... like the speakers don't fit properly.

SO... :hurt: I know this wasn't the best approach but I wanted to seek opinion on what to do next.

My idea was -

1. Remove the 6x9s, and replace the parcel shelf - a clean one with original grills, to cover up the mess left behind by the attempt.

2. Box the 6x9s? (Any comments on where to secure the boxes??)

Thanks to anyone who has read my ramble - guess I've become a bit obsessed with my p10 since it's my first :)
 

·
Registered
Joined
·
1,315 Posts
Well to get the bass... Id suggest turning up the bass on the head unit... Under some sort of settings page...

Make sure you wired the head unit up to the origional wires...
And did you try and bypass the amp?
 

·
Registered
Joined
·
14 Posts
well first off, how deep do you want to get into a sound system?


to start i would suggest getting some better speakers. i would recommend hypnotic, you want bass then go with some subs, dont rely purely on front and rear speakers alone...
 

·
Registered
Joined
·
91 Posts
How did you wire everything? Did you use the factory wiring harness to hook up the power and all for the stereo? Did you use the factory speaker wires from the original harness? Or did you run speaker wires from the stereo right to the speakers?

How good is the Sony stereo? A more top of the line or more towards the bottom of the line?

And, unforts, you would have been better just using some 6.5" for the rear speakers. And been able to avoid cutting the rear deck. You get better bass from round speakers than from 6X9's. Hence why subwoofers are round, not oval like 6X9's. I know this does you no good now cause the damage is done. But now ya know for next time...;)

The stock speakers are 2 ohm i believe. They are meant to be used with the stock 2 ohm radio. Your Sony is 4 ohm, made to be used with aftermarket speakers. So this is gonna throw off the sound you get from the front speakers.
 
1 - 4 of 4 Posts
Top