Infiniti G20 Nissan Primera Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 · (Edited)
I have a 1997 JDM P11. I am getting a noise from the front suspension when I go over bumps, dips and pot holes, especially sharp and fine bumps. Its a strange noise, the noise sounds as though a bushing is bad or there is excess play on some part of the suspension geometry. I changed the following parts and the noise still exists:

1. Both Upper Control Arms
2. Both Lower Control Arms
3. Both inner tie rods
4. Both outer tie rods
5. Both Stabilizer end links.
6. All stabilizer bushings (energy suspension).
7. Both steering rack clamp bushings (energy suspension)
8. Both third link bearing are good.
9. Both Shocks are fairly new.
10. Spindle bearings are good.

I carried it to alignment shop, and alignment and camber are perfect. I am at a lost now, I changed all those parts and the noise is still there, sometimes I feel the noise on the flooring.

If anyone has any idea or suggestions I would appreciate the info and assistance. :cool:
 

·
Registered
Joined
·
321 Posts
Well I am on BC coilovers 8k/6k, fairly low, and on the left side I get a nasty clicking sound which is my sway bar link that has gone bad which I need to replace. But on the right side, I get clunking noise/bottoming out sound which is actually my UCA hitting my strut tower due to no more suspension travel on bigger bumps. Idk if that's what you get but that's my car in a nutshell.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #7 ·
Motor mounts?
My motor mounts are in good condition, they are less than a year old. I do not get any vibrations.

Well I am on BC coilovers 8k/6k, fairly low, and on the left side I get a nasty clicking sound which is my sway bar link that has gone bad which I need to replace. But on the right side, I get clunking noise/bottoming out sound which is actually my UCA hitting my strut tower due to no more suspension travel on bigger bumps. Idk if that's what you get but that's my car in a nutshell.
My P11 is not lowered, stock eight with new springs in front on New SR shocks.


I am wondering if the inner cups on the axles could be making the noise.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top