Infiniti G20 Nissan Primera Forum banner
81 - 91 of 91 Posts

·
Premium Member
Joined
·
5,071 Posts
I like!! I was actually looking for a set of those awhile back. Are you gonna leave that color or go in a different direction?
 

·
Registered
Joined
·
1,525 Posts
Discussion Starter · #86 ·
It has been a while, but the car has been doing well. In the meantime I had been fixing up a P11 I purchased a while back and finally got it running. Nothing fancy there just got it running.

As far as this car goes, I bought a Fujitsubo exhaust back in December and it took awhile for the seller to ship it, but he finally came through sometime last month. I finally had a chance to install it today. Other things I did was install the passenger side fender liner and a couple of the engine area splash guards. I thought I had a full set, but seems not...I only installed the front 2.

Impressions - as a daily the exhaust can't get any better. It's like stock. The VRS 2.5 on there was a bit droney for daily use so this works out nicely. The exhaust tip is nice as well.

Next things up for the car....
- The car drains the battery sitting for a week so I have to disconnect it. Hopefully I'll take the time to do it soon.
- Window Tint
- Dyno at Charles'

I'm probably forgetting something.

 

·
Registered
Joined
·
1,525 Posts
Discussion Starter · #87 ·
So weekend of the 22nd...

Decided to do some brake upgrades. I had bought some parts from a friend and in that lot of parts were some p12 front brakes. I planned on just swapping the 11" brakes from the black P10 once I had upgraded on that car, but since I had the p12 brakes already I decided what the hell.

I redrilled the rotor hats to 4x114.3 using the old P10 rotor as a template. Then once I got the 2nd hole drilled I started using some old 1/2" bits I had laying around to hold the 2 rotors together. Using a drill press helped a lot.

So the B15 Nismo wheels are much more filled out than the wimpy p10 brakes for an overall better look. I also decided to take the time to powder coat the caliper for that ricer touch :) I found a color similar to the brembos and did it that color.



 

·
Registered
Joined
·
1,525 Posts
Discussion Starter · #88 ·
Today I finally sat down to figure out what was causing the battery drain. It looks like it was the factory alarm. It was sucking about 0.15amps and when I pulled the the plug on the control unit for the alarm instantly amp reading went down to 0.010-0.012amps. So thats settled. If I were to put money going in to this, I would have guessed the radio was the culprit. Particularly so once I figured out the "room lamp" fuse/circuit (which includes radio head unit power) was the one causing the drain I thought it was the radio but is was not.

Anycase, another problem solved....:)
 
81 - 91 of 91 Posts
Top